Sign in with
Sign up | Sign in
Your question

Sony smart tv wont connect to internet

Last response: in Networking
Share
January 16, 2013 3:24:13 PM

Hi,

I just received a Sony TV 55HX850 LCD TV.
I am using a Netgear WNDR3700 (v1) as my Wireless Router, connected to my Cable Modem (Motorola), connected to Time Warner Cable San Diego.

The Problem:
I attempt to connect to my wireless network using the Sony TVs Network Preferences either by Scanning for the network selecting it and entering the password, or by using the Smart Detect Button on the router. After doing so, when I "Check the Internet Connection" I receive the following result:

TV Network device: found
Local Network: OK
Internet Access: Failed

If I try hooking up the TV via an ethernet cable, the TV reports "OK"s for everything.
I downloaded the most recent firmware for the TV, but I still can not get the Internet Access to work.

I tried pinging the TV from my Win7 Command Window, and it recognizes it just fine.

My Router is setup as 192.168.1.1
My TV is setup as 192.168.1.45
255.255.255.0
DNS 8.8.8.8.
Secondary DNS: 8.8.4.4.


Any ideas as to how to make the wireless settings on my router compatible with accessing the internet?
Any help would be greatly appreciated!
a b x TV
January 16, 2013 5:22:41 PM

Did you choose the correct wireless security/encryption type and use the correct wireless password?

If you gave the TV a static address in the TV did you also make it static in the router with the TV MAC address?

What do you get when you use the TV and check the server connection (the home button, Settings, Network, Home Network Setup, Server Diagnostics and follow the instructions?
m
0
l
January 17, 2013 12:34:10 AM

RealBeast said:
Did you choose the correct wireless security/encryption type and use the correct wireless password?

If you gave the TV a static address in the TV did you also make it static in the router with the TV MAC address?

What do you get when you use the TV and check the server connection (the home button, Settings, Network, Home Network Setup, Server Diagnostics and follow the instructions?


Hi, thanks in advance for any advice you can provide:

1. On the TV, there is no option to select the appropriate security type, the Sony TV only recognizes that it is WPA. I used the correct wireless password.

Here is what I am currently using for my security on my Netgear Router:

Netgear Router Security Options
None
(IN USE NOW) WPA2-PSK [AES]
WPA-PSK [TKIP] + WPA2-PSK [AES]
WPA/WPA2 Enterprise

2. The IP on the TV is now 192.168.1.4. I did not see where to enter this IP address / MAC address in my Netgear WNDR3700 routerlogin.com settings. If you could tell me how, that would be great!

The MAC address written on the sticker on the bottom of my Router, DOES NOT match the MAC address on the TV, indicated below.

3. I checked the Connection Status on the TV, there was no "Server Diagnostics" or "Diagnostics" option, only "Status"

Connection Method: WIRELESS
Wireless Device on TV: found
Network SSID: mynetworkname
Strength: FULL BARS
Security: WPA2-PSK (AES)
IP Address Setting: AUTO
IP: 192.168.1.4
Subnet: 255.255.255.0
Default : 192.168.1.1
Primary DNS: 192.168.1.1
Secondary DNS: 0.0.0.0
MAC Address: C0:14:3D:69:FF:48
Proxy: Not On


If I hook the TV directly to the Netgear router via Ethernet cable I get:
TV Network Device: OK
Local Network: OK
Internet Access: OK
m
0
l
Related resources
a b x TV
January 17, 2013 1:12:23 PM

You cannot connect properly if the network uses WPA2 and the TV is on WPA. If this TV is less than say 5 years old, it should support WPA2 -- the diagnostic even recognizes the WPA2 wireless, but if the TV does not do WPA2, you have to change your router to WPA-PSK [TKIP] + WPA2-PSK [AES]. I would make that change to see if that fixes the issue and you can determine later if the TV will do WPA2.

If that fails, I would upgrade the firmware: http://www.sony.co.uk/support/en/product/KDL-55HX850

I don't know that TV diagnostic well enough, but the MAC it lists could be the router??
m
0
l
January 18, 2013 4:10:30 AM

Hi,

I changed the WPA2 security to WPA-PSK [TKIP] + WPA2-PSK [AES], and was forced to reduce the signal level down to 54MBPS.

Reconnected to the network again from the TV.

Got:
OK
OK
OK


I can not thank you enough!!!!!!!!!!
You have made someone happy!
m
0
l
a b x TV
January 18, 2013 12:45:29 PM

withtheeye said:
Hi,

I changed the WPA2 security to WPA-PSK [TKIP] + WPA2-PSK [AES], and was forced to reduce the signal level down to 54MBPS.

Reconnected to the network again from the TV.

Got:
OK
OK
OK


I can not thank you enough!!!!!!!!!!
You have made someone happy!
Great! 54Mbps is the price you have to pay for allowing G wireless or WPA/WEP devices to attach to an N router, but it should suffice.
m
0
l
January 31, 2013 1:10:38 AM

How do you change the WPA and reduce signal level?
Sokol96@aol.com
Thnx
m
0
l
!