Sign in with
Sign up | Sign in
Your question

Poor Remote Desktop Performance

Last response: in Windows 7
Share
May 29, 2012 4:29:24 PM

I am currently working with a user to try and improve the performance of their remote desktop connection. This is running over an internal network from a computer running windows 7 to a system running windows server 2008. The user is using RDP to work in Mathcad on the server.

When the user connects to the computer and starts Mathcad the performance is slow and not really usable. I followed the instructions on a few threads here about turning down the Windows 7 eyecandy such as Areo and performance vs quality for the viewing options. I also changed the settings for RDP such as changing display quality to 15bit setting the connection speed to LAN.

The network is Gigabit speed wise and I cannot find any reason for the poor performance. The cusotmer was doing the same thing from Windows XP and had no issues. The computer that they are using RDP on has an ati radeon 3450. On odd thing that occurs is if they go to the system with Mathcad installed and start a session then lock it and then RDP from their desk the connection is just fine and the user is able to work.

Any additional input is appreciated. Please let me know if additional information is needed.

Flare
May 29, 2012 8:18:00 PM

Flareside said:
I am currently working with a user to try and improve the performance of their remote desktop connection. This is running over an internal network from a computer running windows 7 to a system running windows server 2008. The user is using RDP to work in Mathcad on the server.

When the user connects to the computer and starts Mathcad the performance is slow and not really usable. I followed the instructions on a few threads here about turning down the Windows 7 eyecandy such as Areo and performance vs quality for the viewing options. I also changed the settings for RDP such as changing display quality to 15bit setting the connection speed to LAN.

The network is Gigabit speed wise and I cannot find any reason for the poor performance. The cusotmer was doing the same thing from Windows XP and had no issues. The computer that they are using RDP on has an ati radeon 3450. On odd thing that occurs is if they go to the system with Mathcad installed and start a session then lock it and then RDP from their desk the connection is just fine and the user is able to work.

Any additional input is appreciated. Please let me know if additional information is needed.

Flare


It’s important to check what services are running when the RDP session begins in an effort to troubleshoot what could be causing the performance degradation. Also, at the time that the RDP session is connected, have you performed any kind of detailed analysis with Microsoft’s Network Monitor? You might want to also try to change the following autotuning settings:

netsh interface tcp set global autotuninglevel=disabled
netsh interface tcp set global autotuninglevel=highlyrestricted

Jessica
Windows Outreach Team – IT Pro
May 29, 2012 8:51:39 PM

It's possible that the user's network connection is set to something crazy like 10 megabit half duplex. Had this happen to me once at work, just had to go and tweak a setting in the adapter's configuration and got my full speed again.
Related resources
May 29, 2012 9:28:23 PM

Are there any specific services I should be chesking for? I did find the autotuning and currently have the user set to disabled although after fursther research some have reported better performance with it set to highly restricted.

Willard I double checked this and they are currently connected at Gigabit and I double checked the Server box as well and it is also running at Gigabit.

As a test I transferred a 40 GB file and it did reach 99% utilization of a gigabit connection.

Flare
May 29, 2012 10:49:21 PM

Is there any improvement when you change the autotuning setting to highly restricted? Also, have you used Network Monitor while the RDP session is connected as suggested above.

The more information we have about your network, the more helpful our responses can be.

Jessica
Windows Outreach Team -- IT Pro
May 29, 2012 10:53:10 PM

I am awaiting approval to use Network monitor on the system while running RDP. We did see and improvement changing the auto tuning but it still is not back to how smooth it was using XPx64.

Flare
May 31, 2012 12:19:32 AM

Does the performance degradation occur when you connect to your Windows Server 2008 machine from any Windows 7 machine or only this one particular user’s computer?

Is Mathcad actually installed on Windows Server 2008 itself or is it installed within a Virtual Machine by chance? If so, you may want to check out the advice in this TechNet forums thread that addresses those who may experience slow performance of an RDP session to a virtual machine.

Jessica
Windows Outreach Team – IT Pro
May 31, 2012 1:14:19 AM

The degradation occurs with both computers that are being used to connect to the Server 2008 machine.

Mathcad is installed on the server 2008 box. And the only time the connection is slow and unusable is when the user connects to the server 2008 box and launches Mathcad. If the user goes to the server 2008 machine logs in and then starts Mathcad and then locks the box returns to their desk and the uses RDP to connect the connection is fine.

Flare
May 31, 2012 5:51:14 AM

Okay. I’m assuming you are using the latest version of Mathcad that is certified to work properly with Windows 7 architecture.

With that in mind, you might try to improve the network performance by using IPsec task offload as outlined in this TechNet library resource and as suggested by this user on the TechNet forums here.

Also, if you can get approval to use Network Monitor that might be able to give us insight as to what is causing the severe load when an RDP connection and subsequent application load causes the network to hang.

In the mean time, follow the steps to use IPsec task offload and see if that offers any additional improvement to changing the autotuning setting to highly restricted.

Jessica
Windows Outreach Team – IT Pro
!