Sign in with
Sign up | Sign in
Your question

USB Wireless Adapter Not Working On My PC Only

Last response: in Wireless Networking
Share
December 3, 2012 5:52:09 PM



bought this wireless adapter. installed drivers and everything but it doesn't work. when i plug in the device, the network icon in the system tray doesn't change. it won't let me choose any wifi signal. tested it on other computer and laptop and it works no prob. i used to have one before and i remember it worked okay but now it's not working anymore. any help would be greatly appreciated. tia
December 3, 2012 9:02:28 PM

chinoroy said:
http://www.cdrking.com/apanel/modules/products/images/large/11229_1.jpg

bought this wireless adapter. installed drivers and everything but it doesn't work. when i plug in the device, the network icon in the system tray doesn't change. it won't let me choose any wifi signal. tested it on other computer and laptop and it works no prob. i used to have one before and i remember it worked okay but now it's not working anymore. any help would be greatly appreciated. tia


can you give some more information?

your operating system, what brand/model your adapter is...

it would help determine your problems...

Is it the CW-5370E Wireless-N Network Usb Adapter?

I Googled it and here is what i found: it does not work well with vista... it has quite a few issues, so here is what you could try

Run in Compatibility mode for Windows XP:
1. Locate the installation directory and right click the .exe file
2. Select the compatibility tab
3. You can now choose to run the program in Windows XP comatibility mode (make sure the "Run this program as an administrator" box is checked)

~~~OR~~~

If you could connect to the internet some other way: try running the Windows Update and check for Device Drivers.

~~~OR~~~
Install an older version of the drivers: some of the "new" drivers have had problems.

December 4, 2012 4:45:31 AM

windows 7 64-bit. and yeah its the CW-5370E. already tested on other pc with same OS and its working without a prob.
Related resources
December 5, 2012 10:26:41 AM

bump
December 5, 2012 8:54:37 PM

chinoroy said:
windows 7 64-bit. and yeah its the CW-5370E. already tested on other pc with same OS and its working without a prob.

did you try any of the things i said?
December 6, 2012 5:26:08 AM

yes sir. still not working.
!