Sign in with
Sign up | Sign in
Your question

Connection for everything but browser

Last response: in Wireless Networking
Share
December 9, 2012 4:14:44 AM

I am having trouble with my recently purchased laptop. After booting it up I am able to connect to the router, but unable to use internet browsers. I have checked other applications and they seem to be able to access the internet, such as a torrent client system updates and cmd.

So far I have checked the configuration of the network, both on the router and the laptop. As far as I am aware everything is configured correctly, the router is not filtering MACs, I am reaching the DHCP, the firewall does not seem to be blocking browsers, and the browser is not attempting to access any proxies or the like.

I tried shutting off the router and laptop for 15 minutes, about the time the lease was to expire.

Just in case I flushed dns cache and reset winsocks to no avail.

I also changed the DNS server to open DNS, which has had positive results for other computers in the home.

I am wondering if anyone might have some ideas as to how to resolve this. I was debating on trying to set up a static IP for the device and some port forwarding to see if I can force it... Not sure if that would really do anything though.

Hardware-
Router Netgear WRN1000v2
NIC - QualComm Atheros AR9485
OS - Windows 8 (to be replaced)

More about : connection browser

December 9, 2012 8:32:45 AM

Try to telnet to some websites on port 80. It wont actually give anything really usable but you can tell the difference between no access and a connection that does not understand you attempt to open it with a non browser. Make sure you try it via IP address also.

Unlikely it is related to your IP. If you can ping stuff then the basic ip setting are fine. If you can ping by name then your DNS is fine. I would bet it is some great option they hid in windows 8 to protect stupid people from themselves.
m
0
l
December 9, 2012 12:14:26 PM

I know this is going to be unpopular in some quarters but whenever I'm faced with this problem in a system I'm working on, Norton is never far away.

m
0
l
December 12, 2012 6:24:40 AM

Well, I resolved the operating system issue. I have managed to downgrade to windows 7.

I'll get a telnet program to test port 80.

So I tried connecting to an unsecured network available from my backyard. I found that using this network I am able to access the internet through a browser.

Additionaly I found (using CurrPorts, it shows all active ports and what is accessing) that while trying to access my router no ports became opened. While on the unsecured network the browser is using ports 49479 & 49782 - 49791.

As I get a chance I will attempt to attach to other random networks for further testing.

Has anyone heard of this sort of problem before.

And thanks to the both of you for responding.
m
0
l
Related resources
!