Sign in with
Sign up | Sign in
Your question

Guidance for gigabit setup

Last response: in Networking
Share
January 26, 2013 7:41:53 PM

Hi all, let me state that I have absolutely no clue about setting up a network. Now that's over with I've drawn a crappy diagram to quickly show what my network looks like right now:



So I have a fileserver and computer attached to an unmanaged switch which then goes through a 100Mbps homeplug and then down to the router. I implimented the switch in order to have a gigabit connection between my fileserver and PC, and yes both of them have gigabit NICs, but the problem is the traffic seems to go to the router first as my connection is only ever 97-99Mbps. How would I go about fixing this?

Some info:

PC - CMD ipconfig


Fileserver - ifconfig -a


All ideas welcome, as I have no idea what I'm doing :D  Thanks.

More about : guidance gigabit setup

January 26, 2013 9:42:03 PM

Hard to say why you are being limited it is not because the traffic is going though the router.

Because the devices are in the same subnet they talk via mac address after they arp the IP the first time.

I would be suspect of a setting on one of the PC. Also you must have ethernet cable that has all 4 pair of wires to get it to run at gig speed.

This is the key disadvantage of a unmanaged switch. You cannot see what the port speed it negotiated at...unless it has some lights that mean something.

I don't know the command to check the negotiated speed on the PC side maybe some else can help.
January 27, 2013 8:53:55 AM

john-b691 said:
Hard to say why you are being limited it is not because the traffic is going though the router.

Because the devices are in the same subnet they talk via mac address after they arp the IP the first time.

I would be suspect of a setting on one of the PC. Also you must have ethernet cable that has all 4 pair of wires to get it to run at gig speed.

This is the key disadvantage of a unmanaged switch. You cannot see what the port speed it negotiated at...unless it has some lights that mean something.

I don't know the command to check the negotiated speed on the PC side maybe some else can help.


Ah, it will most likely be the ethernet cables in that case. All the ones I have are from router kits from the ISP, none of which have been gigabit so I assume they'd use lower grade ethernet in that case also. I've checked them out and can see orange, white, blue and green cables in the head, whether that is gigabit or not I do not know?

Also the unmanaged port does have lights, I've seen it orange and green at times. It's green most of the time so I assume orange means the computer is off, I can't remember. I did check the pure speed between the two with iperf but forgot to mention, this is the result everytime.

Related resources
January 27, 2013 8:55:59 AM



As mine don't seem have those wire pairs, that must be the problem. Thanks a lot for pointing me in the right direction, I thought all ethernet cables was the same!
January 29, 2013 3:15:55 PM

Just to say incase someone ever stumbles upon a similar situation. Yes it was the cables, new ones arrived today.

January 29, 2013 3:52:38 PM

I just tripped into your post. I was going to let you know that if you look at the printing on the jacket of the cable, it should state the category rating of the cable somewhere on it. category 5e and category 6 cable will carry gigabit no problem. Category 5 (not 5e) will not. Well okay it MAY but chances are better than not that it won't...

Some category 5e cables also tended to be terminated incorrectly, using only 2 pairs of wires instead of all 4 in the cable. This is fine for 10mb and I believe 100 works this way, but gigabit needs all 8 wires...
January 29, 2013 4:27:47 PM

dbhosttexas said:
I just tripped into your post. I was going to let you know that if you look at the printing on the jacket of the cable, it should state the category rating of the cable somewhere on it. category 5e and category 6 cable will carry gigabit no problem. Category 5 (not 5e) will not. Well okay it MAY but chances are better than not that it won't...

Some category 5e cables also tended to be terminated incorrectly, using only 2 pairs of wires instead of all 4 in the cable. This is fine for 10mb and I believe 100 works this way, but gigabit needs all 8 wires...




What this guy said
!