Sign in with
Sign up | Sign in
Your question

XP laptop won't connect to Actiontec C1000A

Last response: in Wireless Networking
Share
December 10, 2012 1:08:49 PM

Hello,
I have Centurylink DSL as an internet provider. They recently replaced my old Actiontec GT701-WG with an Actiontec C1000A. Since upgrading the modem, I can't get my XP laptop to connect. I can get an iPad, Vista laptop, a Windows 7 laptop, and a WII to connect using the exact same settings I had on the old Actiontec.

I've set the C1000A to WPA/WPA2-PSK and TKIP/AES. I do not have an access list enabled. I set the SSID and key to the same settings I had on the original Actiontec. I've upgraded the drivers on my XP laptop to the latest version. I can see the SSID in my list of networks but when I try to connect, it just sits there saying connecting. I've set up my old Actiontec as a wireless switch and can connect with the XP laptop without any problems. I've also connected to a Netgear 802.11N wireless router at another location without problems. What could be wrong with the new Actiontec C1000A? Actiontec support blames the laptop, of course.
a b D Laptop
December 10, 2012 2:42:57 PM

Maybe it's Windows XP that is the problem and as great as that OS was there is getting to be less support for it as Microsoft pushes for the newer OS to be used. It does seem to be the case since all your other devices can connect except the laptop with XP so that 's an indication that the service is working and there is something with the laptop that is preventing a connection. Plus it can still connect to the old router.
Did the new router have Windows XP drivers ?
m
0
l
December 10, 2012 4:15:07 PM

Should I need drivers if I'm connecting via Wifi as long as I have the correct security set up? I connected fine to a Netgear 802.11N router at my parents and don't remember loading any drivers.
m
0
l
Related resources
a b D Laptop
December 10, 2012 4:28:19 PM

Well if you can't connect then why wouldn't you consider finding out if you need drivers for it. The obvious thing here is that all of your other devices can connect so that means that there is nothing wrong with the service or the equipment and there is nothing wrong with your other devices that can connect. So the one thing that is having a problem is the laptop with Win XP. Your other devices are newer and may not have needed drivers but with XP being older it may need drivers . It wouldn't hurt to look.
m
0
l
December 10, 2012 5:27:01 PM

According to the Centurylink website, no drivers required. Actiontec website lists compatible OSes as XP, Vista, Win 7, OS 9+, OS 10+, Linux, & Unix. Is there a way to actually see what's going on while it's trying to connect? I've even tried connecting without any security without any luck. I'm just confused why I can connect to my old 802.11G router using the same security settings (except different SSID, key, & channel) but not the new 802.11N router with the same settings as all my other devices. I've tried setting the new modem/router to 802.11B/G/N, 802.11G/N, and 802.11G only with no luck.
m
0
l
a b D Laptop
December 10, 2012 5:47:39 PM

Just to connect the laptop to the router have you tried an ethernet cable ? Just to establish a connection to verify that it can even connect to the router and that may end up helping with the wireless connection.
If you open up the network connections where you see the path for the connection and you will see the red x where it fails to connect. You can click on that red x to see what the result is and you can see which side of the little house the red x is.
m
0
l
December 10, 2012 6:29:49 PM

Yes I can connect using an ethernet cable without any problems. And my current work-around is to connect my old Actiontec modem (as an access point) to an ethernet port on the new modem/router, then connect the XP laptop via WiFi to the old Actiontec modem. It's working but I would like to eliminate the extra piece of hardware. Plus, as an engineer, I'd like to figure out why I can't connect to the C1000A.
m
0
l
December 14, 2012 4:37:40 PM

I am having exactly the same problem: I got an Actiontech C1000a to move to VDSL, and it won't connect wirelessly with a laptop running Windows XP, even with security disabled. All Ethernet connections work. Prior to the conversion to the C1000a, the laptop connected with no problems, and still connects with other networks. I updated the pertinent drivers in the laptop with no improvement. CenturyLink replaced the C1000a, but the new unit has the same problem.

I'm told, incidentally, that the C1000a will not work with Firefox or Chrome, even though what little documentation there is for the C1000a explicitly says it will. And it does not have "guest" capability, so my plan is to add an access point as you've done. As you said, it would be nice to know what the problem is.
m
0
l
!