Windows 8 and IE 10 unable to use Linksys login

I recently upgraded several of my systems to Windows 8 from XP. This, of course, included the update to IE10.

Now, I cannot log into the router on my network via a Windows 8 system. It works fine if I use a Windows 7 laptop or an XP unit, but on Windows 8, when I go to the router's address, it prompts me for the Username and Password. It takes the password, and then immediately comes back and asks for it again. Another weirdness is that it won't exit when I choose cancel - only if I select the red X in the upper right corner of the authentication window.

I am using a WRT120n for my router.

Any ideas?

Steve
6 answers Last reply
More about windows unable linksys login
  1. slparsley said:
    I recently upgraded several of my systems to Windows 8 from XP. This, of course, included the update to IE10.

    Now, I cannot log into the router on my network via a Windows 8 system. It works fine if I use a Windows 7 laptop or an XP unit, but on Windows 8, when I go to the router's address, it prompts me for the Username and Password. It takes the password, and then immediately comes back and asks for it again. Another weirdness is that it won't exit when I choose cancel - only if I select the red X in the upper right corner of the authentication window.

    I am using a WRT120n for my router.

    Any ideas?

    Steve


    Hi Steve,

    I'm sorry that I don't have a solution for you, other than to say that I have the same issue and that using Chrome works for sure. I'm not running FireFox or any other browser so I can't vouch for them but I suspect it might be at least somewhat related to IE10. I'm working on it so I will post if I come across a solution myself or during my travels on the Internet. Good luck.


    Mathieu
  2. This issue is not limited to Login at the Linksys router.
    It happens with several web-sites (e.g. Strato.de, Forums.pinnaclesys.com).
    Thus it must be due to a combination of changes in IE10 and particular Login procedures of the we-bsites
  3. is there a wayto back-rev to IE9? I am using Chrome and Firefox, but MS apps (i.e. MS-CRM) don't work with anything but IE.
  4. I found the following resolved the issue for me:

    In IE go to Tools, Compatibility View Settings.
    Enable "Display all websites in Compatibility View".

    Hope this helps
  5. This works. go to internet options -- security -- local intranet -- change security level to low.
    This should fix most Local Router GUI issues.
    Hope this helps
    Brian
Ask a new question

Read More

Routers Internet Explorer Windows 8 Windows XP Networking