The installshield engine (ikernel exe) could not be launched interface not regis

when I'm installing a program an error coming that The installshield engine (ikernel exe) could not be launched interface not registerred.
5 answers Last reply
More about installshield engine ikernel launched interface regis
  1. is it only one program in particular that you cannot install? Or does it happen with any program?
  2. EDIT: Those worried faces are meant to be the : and / in file locations. That's pretty hilarious.

    Hello,

    I'm having precisely the same problem (with just one prgram that I'm trying to install: the game Europa Universalis III, known to be compatible with Windows 7 64-bit, which is what I'm running). I tried following the advice in the link that dodger46 posted, but the only folders I have in C:/Program Files (x86)/Common Files/InstallShield are 'Driver' and 'Professional'; there's no 'engine' folder. I tried running the IKernelUpdate.exe anyway, but I get the following error:

    Quote:
    The InstallShield Engine (iKernel.exe) could not be launched.

    Class not registered.


    (This time it's "Class", as opposed to "Interface" not registered). If I go into the C:/.../InstallShield/Driver folder, there are two folders called '9' and '11', both of which contain one folder called 'Intel 32'. So I tried renaming the 'Driver' folder and running the IKernelUpdate.exe again, but the exact same error occurred.

    Any advice would be greatly appreciated. Thanks for reading.

    EDIT 2: It's now saying "Class not registered" instead of "Interface not registered" when I try and install Europa. I'm not sure when or why that changed.
  3. Ha! It was Avast antivirus. I temporarily disabled it and Europa installed fine. :pt1cable:
Ask a new question

Read More

Engine Installshield Windows 7