Sign in with
Sign up | Sign in
Your question

File Sharing 4 Workgroup Computers

Last response: in Networking
Share
January 31, 2013 10:39:49 PM

Ive recently gotten four computers together on the same workgroup. They are all Windows 7 in some form or fashion, and I need them to be able to share the C:\\Users\username files so we can grab files from others desktops and work on data spread across multiple computers.

Ive tried using the homegroup function and Ive also tried just about everything and I cannot get them to access each others folders. No matter what I do it says I dont have the access privileges required to open folders on another computer. On a scale of 1 to 10 I would consider myself an 8 or 9 in being technologically savvy, and after an entire day working on it Im just unable to figure this out.

-All computers are on the same workgroup
-All computers can see each other on the network
-All computers have file sharing enabled
-Firewalls are completely off
-All computers run through the same router (though 2 go through a hub then the router, the other 2 go through another hub then router)


When I go to "advanced sharing settings" and try to give permission to a user on another computer the work group doesn't even appear. I can only give access to local users on each individual computer.

What am I missing?

Thanks so much for any help.
January 31, 2013 11:05:19 PM

First off, turn on your firewalls. You should not be using an end-user computer without the firewall turned on.

Windows 7 by default requires user accounts with password protection to do folder sharing between computers. You can turn this off in the "advanced sharing settings" by selecting "Turn off password protected sharing." However, even this still causes issues sometimes I've come across. Pretty much the only way I've gotten multiple workgroup sharing to work in Windows 7 is to have the same username and password created on all of your computers. Thus, Windows 7 is able to use your local user credentials to pass on and confirm access to remote computers for accessing shared folders.

Second, sharing out a person's user account folder is usually not allowed in Windows. At least, every time I've come across trying to share that folder it has always presented a permission error even after disabling the password protected sharing. This is why they created the Public user account for shared files, which is the equivalent of Windows XP "Shard Documents"
m
0
l
January 31, 2013 11:16:27 PM

Thanks for the response, I should clarify I attempted to make the connection with the firewalls shut down. They are indeed back up, and AVG is set to allow inter network IP range connections through the firewall.

So Ive heard about the multiple user setup before, but I dont fully understand how it works. Currently all the computers have the same username and password, but they are still each individual users on their respective computers. Is there a way to "link" them? Otherwise as far as I can tel they still act as if they were differently named users.

Also that makes sense about the user folder. More specifically I guess we would just like to share specific folders like the desktop folder under a user account.

We've had it working but for some reason it only lasted 5-10 minutes and then told us we had no permission.
m
0
l
February 1, 2013 1:01:16 PM

To try and simplify things and test your permissions and connections, create a new folder on each computer's root C:\ drive, so it is nowhere within the C:\Users folder. Then share out this folder. Go into the advanced share permissions and manually add the user account's name to the list, giving them full access. Since all of the computers in the network have the same username and password you say, this should then allow all the computers to access to that folder.

Start with just one computer, and share out that folder. Record the machine's IP address and the shared folder name. On another computer in the network, set up a mapped network drive to the first computer's \\IP Address\shared folder name and see if it is still giving you an issue then.
m
0
l
!