Sign in with
Sign up | Sign in
Your question

hdd is stuck in PIO

Last response: in Storage
Share
January 20, 2003 9:31:08 PM

Hello, I have been having speed problems with my 20 gig hdd running on a P3 1ghz, 512mb laptop. I was only burning at max 8x speeds in my Yamaha CF1-FUX external writer. At first it was the USB 1.1 ports. But when I got a USB 2.0 adapter it still only writes at 8x speeds. Then, I came here for help. It turns out that my bios put my hdd in PIO mode by default. So I turned it to DMA. And still no luck. In the system settings on Win2k Pro my IDE primary (hdd) is stuck on PIO mode. Is there anyway to force it to DMA?
Thanks,
P.S. Is there any chance that my HDD only supports PIO mode?

More about : hdd stuck pio

January 20, 2003 9:53:25 PM

No, that drive is definately at least ata33.
PIO dives dissapeared a very long time ago, and they got no greater than around 4Gb in capacity.

What you can try is the following, as i too have had problems with getting UDMA to 'stick' in win2k.

A. reinstall the chipset drivers
B. delete and reinstall the IDE channel that is giving you grief.

For some reason the second usually does the trick... and if you have 2 devices on the one channel, its best to enable dma on them one at a time, rebooting between them.


<b>Despite the huge top speeds, amazing acceleration and incredible G-Forces of Top Fuel Dragsters, a standed riced up Lancer often has a larger rear wing.</b>
January 20, 2003 10:49:02 PM

Well, there are no updated drivers for that drive and I tried uninstalling the IDE channel drivers and reinstalling them. It is still stuck in PIO mode. Do I have to upgrade to WinXP :(  for this to work? Any other suggestions?
!