Sign in with
Sign up | Sign in
Your question

BOOTMGR is missing - only when multiple HDDs plugged in not boot order

Last response: in Windows 7
Share
June 4, 2012 2:00:55 AM

So I tried installing Windows on my new machine and did waht seemed to be the recommended thing and plugged in only my SSD into the Sata port, leaving my other drives unplugged until after the installation. Everything went fine and I was able to get Windows 7 up, drivers were installing and everything was peachy, but then...

Then I plugged in my other drives, and when I did so with the computer running Windows immediately recognized them and I could access them, as well as do whatever I wanted. However when I restarted I got the message BOOTMGR is missing. Now, you may be thinking that this is a simple issue of it trying to load from one of those other HDDs, just set the boot order in the BIOS blah blah. But its not. I set the boot order in the BIOS to use the SSD, I set the SSD to the top of the list within the HDDS priority order and still nothing. I then took it a step further and instead of selecting the order manually told it to boot from the SSD flat out, boot from this drive and the same error message came up.

I'm at a lose...

Edit: Oh, and I already did the boot from Windows disc, startup repair thing - didn't help.
June 4, 2012 2:42:56 PM

That does not work either.
m
0
l
Related resources
June 4, 2012 2:57:30 PM

Yes, it boots perfectly if the SSD is the only one connected.
m
0
l
June 4, 2012 3:10:15 PM

Does one of those HDD's have Windows installed on it also? If so, disconnect just that drive and see if it boots properly then. Or, trial and error and see if one particular drive keeps the computer from booting or if any drive will keep the computer from booting.
m
0
l
June 4, 2012 3:15:26 PM

None of the HDDs has Windows installed, and in fact it seems to be a particular SATA port on the Motherboard. The MB has 8 ports, two Sata2 and four Sata3. The optical drive and SSD are plugged into the Sata3 and when another HDD is plugged into one of the remaining Sata3 is when I have the problem.
m
0
l
June 4, 2012 3:18:30 PM

Not a problem when you plug another drive into one of the Sata2 ports?
m
0
l
June 4, 2012 3:24:13 PM

Nope.

Now, here's another wrench to throw into things. The copy of Windows I have, when I choose to boot from the MB and select what device to use, when I tell it to use the optical drive it lists it as AHCI: Blahblahblah. I tried a friends copy of Windows 7 and it had the option to boot from the optical drive as either AHCI or UEFI. If I booted again, and installed via AHCI I ran into the same problem however when I tried it with the UEFI option I have no problems. Windows does show that the SSD seems to be configured differently, showing a GUID Partition Table and all and it has no problems with HDDs in any slot.

However, that's not my copy of Windows, my copy only has AHCI available...
m
0
l
a b $ Windows 7
June 4, 2012 3:45:16 PM

reboot enter bios under boot order remove the usb drives as an boot option
m
0
l
June 4, 2012 3:47:07 PM

Not entirely sure what you're describing lol. I've yet to use a UEFI motherboard. If this problem is caused by some behavior of UEFI or GUID, then I don't think I'll be able to help much. I'll post back if I can think of anything else. And I'll keep an eye on this thread in case I can help later lol.
m
0
l
June 4, 2012 3:49:04 PM

@The Great Randini
They aren't set as an option at all, everything except the SSD and the Optical Drive are disabled from boot order or priority.

@arson94
Basically when I boot from the disc on my disk I only have the option to boot AHCI: OpticalDriveBlahBlah but when I used a friends copy of Windows 7 to test it and went ot hte boot menu I could boot from AHCI: OpticalDriveBlahBlah or UEFI: OpticalDriveBlahBlah.

When I boot from AHCI, and install windows I run into the problem of the booting failure when there is a HDD plugged into one of those aforementioned sata ports. When I install windows via booting UEFI everything is fine, but I can't realy keep it that way because it's not my copy of Windows.
m
0
l
a b $ Windows 7
June 4, 2012 8:16:50 PM

Is it a different version of Windows? If it's the same your product key will be valid for both... Actually some disks have more than one version and when you enter the product key during installation it choses the right one.
m
0
l
June 5, 2012 1:05:10 AM

They are not the same version.
m
0
l
June 6, 2012 2:46:05 AM

Try to configure system like this:

Put the SSD on the first port of SATA 2 or 3 (depending on the type of disk you have). Then the CD/DVD ROM then other drives. Work with one controller at a time instead of mixing and matching SATA 2 & 3...

Then, try plugging only one drive into the system along with SSD and see if it'd boot properly. If all fails, well you know - a reload of windows might just do the trick! :-)
m
0
l
!