Sign in with
Sign up | Sign in
Your question

Internet (W/LAN) works on Macs/Ubuntu but not Windows 7 or XP?

Last response: in Networking
Share
February 6, 2013 10:39:16 AM

I have a Thomson Technicolor TG582n from o2, which is supplied as their latest standard 'Wireless Router V'.

There are 4 laptops (3 on w7, 1 on XP) on the network via LAN with Windows, a Macbook and an iPad which normally both connect via wireless.

Around a month ago the internet suddenly wasn't working on any of the Windows devices via LAN (directly into the router) and wireless. However the internet was still working fine on the Macbook and iPad via both LAN and wireless.

Via LAN the Windows laptops say: Unidentified Network and via wireless they can find the network but get stuck on 'Identifying' when connecting, with 'Limited Connectivity'.

After trying everything the o2 customer support could think of they gave up and sent me a second router. A couple of weeks later the same thing happened, after another call to support they tried changing the wireless encryption which for some unknown reason brought back internet connectivity to all w7 devices via LAN and wireless.

Today the internet has stopped working for a third time on only the Windows machines, my ISP is o2 (UK) and have said that because their router is functioning properly there is nothing they will do.

I have no idea where the issue is as it seems to not be the router, not the cables and it's unlikely to be the laptops as each one is different with w7 or XP.

Does anyone know what I can try? Should I buy another router and use that?
February 6, 2013 12:53:43 PM

What is your TCP/IP configuration? Are you on IPv4 or IPv6? I am not saying tell us your IP address, but how are you getting the IP address, DNS, gateway etc...? Are you statically assigned, or dynamic? Can you ping your router? Can you ping known good addresses through the router?

I suspect you are using DHCP and somehow you aren't getting all the info from your router's DHCP server. Try setting your TCP settings manually if you are on IPv4. I haven't used v6 enough yet to give you a good answer... Sorry.
February 6, 2013 1:15:50 PM

So the internet has come back on the Windows machines now, but undoubtedly it will go again at some point in the future. I didn't see your post while it was still not working, so I didn't get a chance to ping a known good address through the router. I've tried to post some information below that might be what you need to help me?

DCHP Enabled: Yes

IPv4 Connectivity: Internet
IPv6 Connectivity: No Internet Access

DynamicDNS: Disabled

Obtain an IP address automatically is ticked, as is Obtain DNS Server address automatically. The router is running it's factory settings:

1. Device
1.1 Product Name : O2 Wireless Box
1.2 Device Name : TG582n
1.3 Serial Number : Hover to view ***********
1.4 Software Release : 8.4.4.J.AE

2. ADSL
2.1 DSL Status : Up
2.2 Uptime : 1 days 21 hours 38 mins 8 secs
2.3 Type : ADSL2+ Annex A
2.4 Line Rate (Up / Down) : 1178 Kbps / 6218 Kbps
2.5 Noise Margin (Up / Down) : 6.1 dB / 3.9 dB
2.6 Attenuation (Up / Down) : 28.3 dB / 46.5 dB
2.7 Power (Up / Down) : 12.1 dBm / 18.3 dBm

3. Internet
3.1 Interface Name : O2_ADSL2plus
3.2 Connection Status : Connected
3.3 IP Address : xx.xx.xx.xxx

4. Wireless
4.1 Wireless Network Name (SSID): O2wirelessxxxxxx
4.2 State : Enabled
4.3 Interop : 802.11b/g/n
4.4 Security Mode : WPA

There are 3 w7 machines and 1 XP machines, so next time it happens I could try setting TCP manually on one to see if that works?
Related resources
February 6, 2013 4:06:02 PM

That's what I would try. Don't wait until it flakes out again though.. Just figure out what your IP settings should be and set your IPv4, disable IPv6 it sounds like on yours...

In your router, you might want to, if it supports it, map the MAC address of the specific machines to the given IP addresses...

Make sure you set the gateway, and DNS as well..
February 6, 2013 6:44:30 PM

OK I've done that on the 2 of the 4 Windows machines I use most regularly and I'll see what happens... I didn't set an alternate DNS, is that standard?

Should I now make these 2 IP addresses unavailable on the DHCP enabled router to stop duplicates or do I not need to worry about that?
February 7, 2013 12:45:02 PM

What I did with mine since I have a Linksys router is...

192.168.1.0/24 address space available.
192.168.1.1 reserved for the router itself.
192.168.1.2 through say 100 reserved for things I want to set statically.
192.168.1.101 through .253 put into the DHCP pool
I have MAC bound certain devices that I want to be statically assigned when they are on my WiFi, specifically our phones, so that they are in my hosts table on my machines. That way when the WiFi serves out DHCP, to those specific MAC addresses, they are given IP addressing and default routes that I defined... So I can access my Droid from my workstation etc...

It's extra work, but worth it...

I am still mulling over your issue. I am curious. Is your router at the latest firmware?
February 7, 2013 2:56:41 PM

I did some searching and found this online re: firmware:

Quote:
this router is designed to be supplied as a managed device meaning it is configured and updated automatically via a TR-069 server at the ISP.

You cannot get hold of legitimate copies of the firmware from Technicolor and even if you did you'd have to convince the router it was 'talking' to a TR-069 server because at least when I looked into it there was no way for the user to upload firmware or at least not an easy way.


The router is only a couple of weeks old so I would assume it has the latest firmware that the ISP (O2) can provide.

Do you think it is something to do with the router? I would be willing to buy a new router if you think that the router is most likely where the issue is.
February 7, 2013 5:41:07 PM

Assuming our ISP keeps up with firmware, it should be fine...

For what it's worth. Try calling your ISP and tell them you are having connection problems with your Windows boxes. Don't even mention the Apple stuff, that will get them laser sighted on "it works here so it must be your problem:, and you won't get anywhere with it... It's possible that the problem is with the Windows boxes configuration, but if you were using DHCP, the router should be providing the network configuration...

Have you tried the Macintosh with a wired connection? Is it possible they have something incorrect in their router config that is shutting down the wired ports?
February 7, 2013 6:29:10 PM

The Mac worked through both wired and wireless, it really is very strange.

The only thing with not mentioning the apple gear is that there will be notes on my account that state I've called in the past with a weird working on Mac, not on Windows problem.

We've been fine for 24 hours now but we'll see...
!