Sign in with
Sign up | Sign in
Your question

Connecting two PCs simultaneously to upstairs wifi router and wired to each othe

Tags:
  • Routers
  • WiFi
  • PCS
  • Networking
Last response: in Networking
Share
February 10, 2013 10:12:55 PM

So, I've got a cable modem/wireless router box upstairs working fine. A couple of PCs attached to it by Ethernet cable. Downstairs I've got a Windows 7 PC and a Windows 8 laptop connected to the router (and Internet) via wifi. Now I also want to join up the downstairs PC and laptop together. I already do this via wifi as they’re on the same network but it’s slow.
I have a switch and I've had partial success connecting both machines. They're picking up Internet via wifi and the other machine via Ethernet. It worked for a while but then I got the “Windows Has Detected An IP Address Conflict”.
Looking online I see a whole load of conflicting advice. “You can’t do it with a switch.” Well I did, but it’s flaky. “Try static IPs”. I had a quick go. Wasn't fully sure of the best settings and I lost the internet connection. I tried bridging the LAN and wifi connection, but with mixed results.
I also have a spare DIR615 DLink router which I haven’t tried yet. There wouldn't be any “Internet” connection going into it. And I would need to switch off its wifi broadcast.
Just want to know what the recommended approach is with this setup before I try any more experiments. The ideal is to have them simultaneously using the wifi for the internet signal from upstairs and a cabled connection to each other for fast file transfer.

More about : connecting pcs simultaneously upstairs wifi router wired othe

February 10, 2013 10:38:42 PM

There's no reason you can't have both the desktop and laptop connected via wire, while each is simultaneously connected via wireless to the internet router. They don't even need to use a switch. You can simply run an ethernet cable between them. In fact, if you're trying to use that second router as your switch, that could be causing the IP conflict. By default, its DHCP server is ON and probably using the same network settings as the internet router (e.g., 192.168.1.x). But you can avoid that conflict by either changing the second router's network to something else (e.g., 192.168.2.x), or just eliminating it completely. You shouldn't even have to configure the desktop and laptop wired adapters. They should automatically configure themselves on the 169.254.x.x network. It just works.
February 10, 2013 10:52:07 PM

Thanks eibgrad. I haven't tried the router yet; just the switch and as far as I know that doesn't have DHCP?
I'll try the direct cable connection, no switch, but I think I've tried this some months ago.
Just thinking, could it also be that the desktop can see the laptop both through the wifi connection and through the ethernet cable? This could make it look like two different laptops with the same IP? Maybe what I need is something that says: as soon as I connect you both with ethernet cable, stop seeing each other over wifi, but still see the internet over wifi. Then as soon as I remove the ethernet cable, start seeing each other again over wifi.
Related resources
February 10, 2013 11:26:21 PM

You can establish as many network connections on the desktop and laptop as you have wired/wireless adapters, even to the same machines (assuming they have as many adapters as well). This is all perfectly normal. The ONLY thing you need to do is make sure each uses different networks (192.168.1.x, 192.168.2.x, etc.). If you don't, THEN you get the IP conflicts reported by Windows. Also, Windows naming service will only be bound to ONE of those networks, so if you attempt to reference some other machine by name, it will only respond over one of the networks. To access the machine via the other network you'd have to use the explicit IP address (e.g., 192.168.2.100).

Beyond that, there's nothing else to do! It's really that simple. None of this telling one network not to see the other or anything like that. It’s much simpler and basic than you’re imagining.
February 11, 2013 11:39:07 PM

So, armed with this advice I did some more playing, experimenting and web searching. What I have now seems stable and fast. Here's what I've done.

I set static IPs on both the downstairs machines. I generally saw IP addresses as 1 per machine, but as I'm sure you know it’s one per network device. So I've kept the wireless network connection on each machine as automatic DHCP. Happily picking up 192.168.0.7 and 192.168.0.118 or whatever the router gives them next time. (Hmm… Why 118? I don’t have *that* many laptops/phones/consoles).

I've changed the wired Local Area Connections on each machine to static IP. (Network and Sharing Center, Change adapter settings, local area connection GBE, properties, IPv4 properties) I kept it simple because the wire is not for Internet or anything but file transfer. Following your advice I set 192.168.2.2 on the PC and 192.168.2.3 on the laptop. Subnet 255.255.255.0. Gateway and DNS all blank.

The connection was appearing as Unidentified network, Public Network and I couldn't ping the other machine. I'm using Windows 7 Home Premium on the PC. Apparently you can't change this in home premium, only in pro, but I took a risk on a recommended reg file download from http://www.sevenforums.com/tutorials/71408-unidentified... which allows you to set unidentified networks as Private and therefore I guess more trusted.

Now the connection was looking ok from one side but not so hot from the other side. This is when I uninstalled the demo copy of McAfee on the Win 8 laptop which was telling me it had expired but was still messing with some firewall settings.

The other thing I did this evening was to do one thing at a time and reboot after each change, rather than impatiently trying 3 things at once with no reboots. :-)

And so it's working well so far. Ping working both ways on the static 192.168.2.2 and 192.168.2.3 addresses. Web browsing over wifi is fine. File transfer is good. 8GB in 3 minutes. Would have taken ages over both their wifi connections.

Just hoping now it stays stable when I look at it again tomorrow. :-)
February 12, 2013 12:03:17 AM

P.S. If you want to use names instead of explicit IP addresses, you can add those names and ip addresses to your hosts file on each machine ( C:\WINDOWS\system32\drivers\etc\hosts ):

192.168.2.2 abbott
192.168.2.3 costello

Not strictly necessary but a little easier to work with.
!