Netgear WNA3100 802.11 b/g/n, urgent help?

I purchased this adapter to connect my desktop to my router, probably around 6 meters away.

When I first connect, it varies from 18-24mbps, this is ideal, but the problem is whenever I download any information, not loading webpages or such, only watching videos from youtube and downloading games, it drops to 2mbps, and won't return to its normal speed.

This is a disaster since it takes forever to download any games, and slows down any game I can bear to waste time downloading.

It isn't my internet, tried my laptop earlier and it had solid d/l speed, there isn't another thing on my wifi at the moment, apart from a laptop doing nothing (sleeping)

I tried re-installing the driver and still nothing.

Please help!
8 answers Last reply
More about netgear wna3100 urgent help
  1. return it if you can and buy a PCI or PCIe card

    most people have problems connecting a a reliable speed.
  2. Emerald said:
    return it if you can and buy a PCI or PCIe card

    most people have problems connecting a a reliable speed.


    Is PCI more reliable? Also how easy is it to fit / add to the computer, I'm not exactly good at that type of thing..
  3. Is the router in the same room or same floor as the computer ? If it is then you could possably use an ethernet cable to connect to the router and get a much better connection.
    If not and you want to get a slot adapter they are very easy to install and make sure that you follow directions since you don't have experience. The slot card will come with instructions.
  4. inzone said:
    Is the router in the same room or same floor as the computer ? If it is then you could possably use an ethernet cable to connect to the router and get a much better connection.
    If not and you want to get a slot adapter they are very easy to install and make sure that you follow directions since you don't have experience. The slot card will come with instructions.


    Sadly I am on a different floor. I don't particularly want to buy anything new, since my friend has almost the exact same conditions (range, internet, broadband service) and he is getting the same d/l speeds with the same adapter as his internet states.

    I tried reinstalling as I said, I just don't know what to do.
  5. Try changing to a different channel on the router , the channel your using may have interference on that frequency.
  6. inzone said:
    Try changing to a different channel on the router , the channel your using may have interference on that frequency.


    Sorry but, how do I do that? It seems there is no obvious way
  7. To change the channel you need to go into the routers settings and in the wireless set up if you choose basic wireless set up you will have both bands and each one has a drop dowm menu for channel selection.
  8. old thread, but just purchased the wna3100 N300 adapter.

    I uninstalled all netgear software. and installed Software Version 1.1.2.16 found here:
    http://downloadcenter.netgear.com/en/product/WNA3100
    follow the installation instructions.

    The new Software Version 2.1 (Supports Win8), mainly Netgear Genie, messed with the connectivity.

    I was still able to connect with Software Version 2.1 as long as I changed my modem settings to WPA AES or TKIP. Then again, I had to do alot of work to change the other 15 devices, which half do not do well in WPA and need to constantly re-enter code key. Determined to troubleshoot and find a way to make this adapter work in WEP, going back to a previous software did the trick. I am currently running win7-64
Ask a new question

Read More

Connectivity Connection Wireless Networking