Sign in with
Sign up | Sign in
Your question

Computer will not automatically enter sleep mode. ever

Last response: in Windows 7
Share
June 6, 2012 3:18:36 PM

I've been having this problem for some time. Sometimes it works, sometimes it doesn't. I can manual enter sleep mode and it seems to work fine. Though I have had problems with it immediately waking up in the past, but I did manage to some how resolve that issue. However now, it will not automatically enter sleep mode. I've tried everything, I've read every article, I've changed all my settings and configured them to allow my computer to sleep. I'm not in a homegroup, went as far as locking all my folders to not share with anyone. I used the command prompt and typed:

powercfg -requests and it dislpays this: FileSystem\srvnet and active remote client has recently sent requests to this machine.

I tried disabling the internet from the computer, still not sleeping. Tried requestoverride command by entering :

powercfg -requestsoverride \FileSystem\srvnet

the result is: An unexpected error condition has occurred. Unable to perform operation. You may not have permission to perform this operation.

Yes, I am running cmd as administrator. This has been pretty frustrating as I have no idea why nothing is working. I'm confused lost and I'm just posting on forums in hopes that someone out there has a fix for this. Thanks for your time.
June 6, 2012 3:42:21 PM

i know this is a dumb question on my part, but how sensitive is your mouse? (if you have one), try turning it upside down, i have that issue with my desktop, the slightest motion anywhere in the room with my computer will budge the mouse ever so slightly and the computer will wake from sleep, gets annoying with vlc and movies too always have to flip the mouse over so it doesnt move
m
0
l
June 6, 2012 3:42:35 PM

bogus666 said:
I've been having this problem for some time. Sometimes it works, sometimes it doesn't. I can manual enter sleep mode and it seems to work fine. Though I have had problems with it immediately waking up in the past, but I did manage to some how resolve that issue. However now, it will not automatically enter sleep mode. I've tried everything, I've read every article, I've changed all my settings and configured them to allow my computer to sleep. I'm not in a homegroup, went as far as locking all my folders to not share with anyone. I used the command prompt and typed:

powercfg -requests and it dislpays this: FileSystem\srvnet and active remote client has recently sent requests to this machine.

I tried disabling the internet from the computer, still not sleeping. Tried requestoverride command by entering :

powercfg -requestsoverride \FileSystem\srvnet

the result is: An unexpected error condition has occurred. Unable to perform operation. You may not have permission to perform this operation.

Yes, I am running cmd as administrator. This has been pretty frustrating as I have no idea why nothing is working. I'm confused lost and I'm just posting on forums in hopes that someone out there has a fix for this. Thanks for your time.


Have you tried an sfc /scannow from an elevated command prompt yet? Worth a shot!
m
0
l
Related resources
a b $ Windows 7
June 6, 2012 4:09:21 PM

Not sure if this helps.... But i found this on a website (copied and pasted):

http://social.technet.microsoft.com/Forums/en/w7itproui...



I found the solution for my sleeping trouble... well... the computer anyways...

running powercfg -energy

showed the \FileSystem\srvnet was preventing sleep -

I saw the MS folks saying to update the network adapter, and there was an update (wasn't showing up in windows update, just the right click update driver via manager), and that didn't work.

I even enabled the reg key for the 'allow sleep with remote opens' - and that didn't work..

Even allowed machine to enter sleep while streaming via the power cpl - didn't work

Finally went to:
Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings

And under media streaming - blocked all - and that did the trick! I don't know if there's another way to allow streaming and enable sleeping, but for now, beats running all night long after waking for a time update etc... :-)

Good luck -
Geoff
m
0
l
June 6, 2012 4:24:16 PM

Probably not applicable...but having VLC running on my machines (even not actively playing) prevents sleep mode...as does uTorrent.

Good luck!
m
0
l
June 6, 2012 4:57:21 PM

Best answer selected by bogus666.
m
0
l
June 6, 2012 5:02:26 PM

Chainzsaw said:
Not sure if this helps.... But i found this on a website (copied and pasted):

http://social.technet.microsoft.com/Forums/en/w7itproui...



I found the solution for my sleeping trouble... well... the computer anyways...

running powercfg -energy

showed the \FileSystem\srvnet was preventing sleep -

I saw the MS folks saying to update the network adapter, and there was an update (wasn't showing up in windows update, just the right click update driver via manager), and that didn't work.

I even enabled the reg key for the 'allow sleep with remote opens' - and that didn't work..

Even allowed machine to enter sleep while streaming via the power cpl - didn't work

Finally went to:
Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings

And under media streaming - blocked all - and that did the trick! I don't know if there's another way to allow streaming and enable sleeping, but for now, beats running all night long after waking for a time update etc... :-)

Good luck -
Geoff



I came across this same article before and had tried that same solution and it didn't work. However, for some reason, blocking all media streaming worked this time. I ran that sfc scan Benji720 suggested, but it still didn't work after that. But then I changed the media stream settings to block all, and VIOLA! My computer to sleeps when I tell it too. Thank you everyone for your prompt replies.
m
0
l
a b $ Windows 7
June 6, 2012 5:04:19 PM

Right on...so that fixed the issue? Just so we have future reference if anyone has similar problems.
m
0
l
June 6, 2012 6:40:38 PM

Blocking all media streaming under advance sharing settings in the Network and Sharing Center worked for me. The thing is, I have no media streaming at all. I do have my computer synced with my xbox 360 through Windows Media Center, but it was still not going to sleep even if the xbox was turned off and Windows Media Center uninstalled from it. So it may have something to do with that since WMC is just terrible.
m
0
l
December 10, 2012 12:38:54 AM

In Power Options / Multimedia Settings, set it to "prevent idling to sleep" --- this will save you a lot of money in nerve pills! In other words, it fixes the problem!
m
0
l
August 4, 2013 7:40:12 PM

I found a solution in this thread.

Take all the computers on the network out of the homegroup. Turn them all off. Boot your computer and re-create the homegroup. Add each other computer back in.

I did this and the "active remote client" hasn't shown up yet.

BTW I monitored the powercfg requests using the following batch file, run as administrator:

echo off
:fooey
time /t
powercfg -requests | find " "
: Delay 30 seconds
ping 10.1.1.1 -n 1 -w 30000 > nul
goto fooey
m
0
l
August 5, 2013 11:20:18 PM

The above fix didn't hold up.
m
0
l
August 7, 2013 8:18:08 AM

This solution from this other thread has been working for me for several days now:

Run the DOS command powercfg /requestsoverride driver srvnet system as administrator.

Powercfg will still show the client requests but they will not prevent sleep.
m
0
l
January 11, 2014 8:20:13 PM

bilofsky said:
This solution from this other thread has been working for me for several days now:

Run the DOS command powercfg /requestsoverride driver srvnet system as administrator.

Powercfg will still show the client requests but they will not prevent sleep.

Don't forget the "system" piece and the full path. It should be:

powercfg /requestsoverride driver \FileSystem\srvnet system

Then run:

powercfg /requestsoverride with no additional arguments to see if it added it successfully. You should see something like:

[SERVICE]

[PROCESS]

[DRIVER]
\FileSystem\srvnet SYSTEM


m
0
l
!