Sign in with
Sign up | Sign in
Your question

Two USB Sound Devices, How to Make Them Play at the Same Time?

Last response: in Windows 7
Share
June 6, 2012 9:57:41 PM

I have Windows 7 64 bit, Realtek onboard sound.

I have USB speakers and today bought a USB headset. I can't seem to get them to both to work at the same time when plugged in. I usually like to keep the headphones around my neck while using the mic, but listen to my nice Bose speakers. When it gets to be late at night, just put the headphones on and turn off the speakers. Either way, the mic needs to work at both times.

They are both plugged into USB slots in the back of the computer.

Any suggestions?
a b $ Windows 7
June 6, 2012 11:04:23 PM

mortal888 said:
I have Windows 7 64 bit, Realtek onboard sound.

I have USB speakers and today bought a USB headset. I can't seem to get them to both to work at the same time when plugged in. I usually like to keep the headphones around my neck while using the mic, but listen to my nice Bose speakers. When it gets to be late at night, just put the headphones on and turn off the speakers. Either way, the mic needs to work at both times.

They are both plugged into USB slots in the back of the computer.

Any suggestions?

When you plug the headset in, it negates the speakers.
June 6, 2012 11:23:57 PM

Well yeah, but is there a way to make it not do that? It's obviously controlled by the computer somehow.
Related resources
a b $ Windows 7
June 6, 2012 11:45:13 PM

The "easiest" way I have found: Right-click on speaker/volume icon in the tray area, "Playback Devices", click the one which should play. This will not affect your microphon (it's on "Recording Devices" tab)
a b $ Windows 7
June 7, 2012 3:51:04 PM

You can swap between the outputs easily enough without changing the input device; the real problem is getting two separate output devices to play at the same time.

The only way I know how to do it is if the application allows you to manually select which audio device to use; you can then override the windows default. [Windows REALLY needs to add a switch to allow users to do this manually...]
!