Sign in with
Sign up | Sign in
Your question

Upload > Download

Last response: in Wireless Networking
Share
December 29, 2012 7:32:51 PM

Router: D-link Xtreme N Gaming Router DGL-4500

Just updated our Verizon FIOS to 50/25 Mbps. The wired computer gets ~52/~28 on an average of 10 tests.

The wireless computer which is not far away, is averaging after 10 tests exactly:
Download Speed: 28625 kbps
Upload Speed: 33669 kbps

The wireless computer is using a Rosewill RNX-N2X Wireless N Adapter which has been fine for a long time with our prevous 20/5 (Was getting 22/6) and never dips below 76% signal. No G devices are connected, all of the testing has taken place with only the main wireless computer connected.

The only thing I saw is that the wireless adapter may not be a "true" N? Draft N or something I believe? The settings shows it supports 5Ghz as well, but when the router is set to 5 Ghz it is not seeing the network. Not sure exactly what to do. I know wireless isn't perfect, but I thought I could at least get closer to the 50Mbps, and wondering why my upload is much higher at all times.

More about : upload download

a b F Wireless
December 29, 2012 7:43:36 PM

Some wireless routers that have dual band will have simultaneous dual band or you will have one band being accessed at a time so you may have to diable the 2.4 ghz band to use the 5 ghz band. Each band can also have it's own secuity key and they don't necessarily have to be the same so you may have to set up the 5 ghz.
You can also try changing the channel on the 2.4 ghz band
m
0
l
December 29, 2012 7:46:01 PM

I've tried changing the channels, didn't help. In the options if you choose 5 ghz it disables the 2.4 and likewise, my adapter doesn't see the network even manually trying to add it when the router is set to 5 GHz.
I'm just trying to make sure I get as much as I can from the wireless PC.
m
0
l
Related resources
a b F Wireless
December 29, 2012 8:12:36 PM

Maybe it's time for a new wireless adapter ? Also the D-Link router is quite old , I had the a D-Link gaming router and I think it was the 4200 model , it was called the Gamers Lounge. I wasn't impressed and went with a Netgear and then a Linksys. Always looking for that elusive best router.
I always try to have my desktop connected by ethernet cable because it is the best way. A wireless connection is always less , except now they have come out with gigabit wireless called Ac , so now you have b/g/n and the new Ac.
m
0
l
December 29, 2012 8:53:08 PM

I checked off "WMM Enable" in the router settings as suggested by someone. Now on tests I get an average of 56/26 with a steady ping. Seems to be working fine now.
m
0
l
a b F Wireless
December 29, 2012 10:01:00 PM

That is very interesting.
According to the IEEE standard for 802.11n if you disable that feature you are now in non compliant with the standard and other devices are not suppose to negotiate speeds higher than 54m. Ie you can't use mimo or wide channels. This non compliant issue is the same reason you must run WPA2 and AES to get 300m.

It should actually run slower. I suspect someone is not following the standards correctly for it to do what it is doing.
m
0
l
a b F Wireless
December 29, 2012 10:08:39 PM

The VMM is in the QoS and should have been enabled by default and is recomended in the user manual to be so. I don't know why it was off in your router.
m
0
l
a b F Wireless
December 29, 2012 10:15:34 PM

inzone said:
The VMM is in the QoS and should have been enabled by default and is recomended in the user manual to be so. I don't know why it was off in your router.



Hmmm I read his post the other way. I read it that he turned it OFF to fix the problem. I too have always left that on since it caused issues anytime I turned it off trying to figure out what it actually did.
m
0
l
December 29, 2012 10:27:42 PM

In my "advanced wireless settings" I have:

WLAN Partition [ ]
WMM Enable [ ]
Short GI [X]
Extra Wireless Protection [X]

I checked WMM Enable and unchecked short gi and extra wireless protection. I was downloading torrents around 6MB/s+, however I noticed in games i get a random minor lag spike every now and then, sigh.
m
0
l
!