Sign in with
Sign up | Sign in
Your question
Solved

W7 64b Pro won't show HD's in My Computer...?

Last response: in Windows 7
Share
February 21, 2010 1:58:39 AM

So the drives in question are 3 Seagate 1.5tb 7200.11 HD's.

They show up fine in the BIOS where they are all listed as slaves (ga-p55-ud4p) and in Device Manager - which lists them all as working properly. I cannot distinguish one from another in Device Manager, and the one that is working has very important legal files on it.

However, I can only see one in "My Computer" - but the other 2 I cannot "see" them so I cannot access them.

The one I can see is the oldest one and was not altered when the older PC was upgraded (upgraded all components except HD's and OS). I also kept 2 older WD 500AAKS which are both working fine as well.

The two I cannot see: One is brand new. The other was reformatted to blank (quick) on another PC (which was upgraded to Win7 at that time) which subsequently could not see the drive. I moved it over to this faster PC and still cannot see it.

All these 1.5tb Seagate drives are CC firmware so are not part of the older firmware issue. None have any 1.5gb jumpers on them.


Mobo drivers are all fully up to date - I just reupdated all of them. Windows is up to date. Windows does show in the Troubleshooter that a USB controller driver is not found and I cannot seem to find out how to install it (via uninstalling it, updating drivers, etc etc - question thread here: http://www.tomshardware.com/forum/270613-30-ud4p-win7-6... ]

ga-p55-ud4p rev.1, i7 860, 4gb gskill eco ram, xfx 5890, Seasonic X750 gold, very cool system...


What gives? Any ideas?

Any help would be GREATLY appreciated, I am out of solutions.

More about : 64b pro show computer

a c 215 $ Windows 7
February 21, 2010 2:06:43 AM

I'll assume the missing drives are empty when I say this:

By default, Windows sets Computer to hide any empty drives connected to the system. Open Computer and go to Organize, Folder and Search Options, click the View tab and uncheck the box called Hide empty drives in the Computer folder.

m
0
l
February 21, 2010 2:12:52 AM

That was a great suggestion - I did have that checked. I unchecked Hide Empty Drives and did not see them in My Computer after a Refresh.

I rebooted, still not seeing them!?

PS- Yes they are both empty.
m
0
l
Related resources

Best solution

a c 215 $ Windows 7
February 21, 2010 2:14:48 AM

If neither one is formatted, you will need to format them first by going to the Disk Management wizard (type "diskmgmt.msc" into the start menu - minus the quotes of course). If your drives are detected by the BIOS, there is no reason why they won't show up in disk management either.
Share
February 21, 2010 2:19:10 AM

Yes I see them both there. While the others are listed by their drive names and are given a blue color - the other two are both unamed/unallocated and given a black color.

This appears to be my problem - I will update shortly if it is not. If it is, I will select best answer so it may be resolved.

Thank you so much for your help.

I feel like a fool - but how else would I learn to type diskmgmt.msc unless taught :(  There really ought to be a visual or link lead into this area that is pretty easy to find - on the other hand I suppose Microsoft expects noobs like me to be buying PCs prepared and not trying to bushwhack their way along!

Grateful for your time!
m
0
l
February 21, 2010 2:25:25 AM

Best answer selected by divpers.
m
0
l
February 21, 2010 2:26:45 AM

That was correct. I spent hours trying to resolve this myself before coming here - I should learn by now to ask for help sooner!
m
0
l
a c 215 $ Windows 7
February 21, 2010 3:13:01 AM

Glad I could help!
m
0
l
August 3, 2010 9:43:31 AM

divpers said:

I feel like a fool - but how else would I learn to type diskmgmt.msc unless taught :(  There really ought to be a visual or link lead into this area that is pretty easy to find - on the other hand I suppose Microsoft expects noobs like me to be buying PCs prepared and not trying to bushwhack their way along!

Grateful for your time!


You right-click on "computer" and choose Manage. That gives you access to a bunch of stuff, including Disk Management.

It's easy to remember.
m
0
l
!