Ethernet connection not working

I'm in a military hotel for the next few months and am having some internet issues. My Windows 7 desktop cannot use the ethernet connection for some reason while it works just fine on my Macbook Pro. When I run ipconfig in CMD I'm seeing a 169 IP address which from my googling of the issue I understand is invalid. When I run network diagnostics to try to fix it the result is that "Local Area Connection" doesn't have a valid IP configuration, and that this is now FIXED. My network and sharing center screen even claims I have internet access for a few seconds (instead of a red x between the network and internet icons) before dropping out again.

I've been trying all kinds of stuff to try to fix this like ipconfig /release and /renew but this doesn't work because it says an address hasn't been associated with the network endpoint and so no operation can be performed "while it has its media disconnected."

This is driving me nuts...

edit- also worth noting that the connection works for like 10 seconds after I reboot my computer before cutting out again.
9 answers Last reply
More about ethernet connection working
  1. Which version of Windows 7? The problem that you are having is the Windows 7 unidentified network problem. It is an easy fix for the Pro/Ultimate/Enterprise versions using the policy editor like THIS. If you have Home Premium it is a bit more of a problem to fix.
  2. the 169 ip address means your not getting an IP address from the DHCP. Do you have a static IP address? Have you tried updating the drivers? It could be that your ethernet port is corrupted also.
  3. eldapeeze said:
    the 169 ip address means your not getting an IP address from the DHCP. Do you have a static IP address? . . .
    If he had a static IP address, he would not be getting the 169.x.x.x address, the default Windows address when it fails to get a real address assigned.
  4. Quote:
    well I don't see you fixing the problem now do we?
    Quite an inappropriate comment, and WRONG. If you read my post, I asked for more data and gave him a quick solution in a link to using the policy editor to fix the issue unless he is running Windows 7 Home Premium, which unfortunately lacks the policy editor and takes more effort to fix.
  5. well I don't see you fixing the problem now do we? eldapeeze < please don't insult others in the forums
  6. I'm running Windows 7 64bit Home Premium.

    My mobo has two ethernet ports, neither works. It was working just fine the other week while I was still at home. I've tried updating my network adapter drivers. I do not have a static IP.
  7. Ok, so Home Premium is a little more work for the unidentified network issue. You need to go HERE and download the file and follow the guide for Option 2, number 2.
  8. Tried that, it didn't do anything to help. For some reason it shows two networks ("Network 5" and "Network 7") which are labeled as public networks but there is no internet connection. If I run the troubleshooter, the network briefly is renamed to "Lee Lodging AP02" which is also the name of the wireless network and is said to have an internet connection for a few seconds before going back to having no name and no connection. Same as before.
  9. Try the steps in each of the two answers HERE (the problem is harder to fix without having a policy editor).
Ask a new question

Read More

LAN Connection Ethernet Card Networking