Sign in with
Sign up | Sign in
Your question

Clean Windows 7 install on new Asus K55VM

Last response: in Windows 7
Share
June 11, 2012 3:31:31 PM

Hi all,

I'm struggling to do a clean install of Windows 7 on my new Asus K55VM laptop.

I'm not entirely newbie, but all this UEFI mumbo-jumbo wasn't around the last time I bought a laptop.

First, I made the recovery ISO's. Then, I downloaded a Win 7 64bit Home Premium image from Digital River, copied it to a USB disk, and did the whole MS "Windows 7 USB DVD Download Tool" thing. Boots fine, but asks for a CD/DVD driver. However, none of the drivers available is accepted. So I burned a DVD instead, which made it pass the driver issue.

Then I managed to clear the "OS" partition, but the installer says "the selected disk is of the GPT partition style" and Windows can't be installed. I've managed to boot in "UEFI" mode on a Windows 7 Ultimate DVD and finish the install, but since I don't have a license, thats a dead end.

I've read somewhere that I could change the "AHCI" setting in the bios, but not sure if that would cause any performance issues, or even help me anyway.

What would be the right thing to do here? Should I delete all partitions? Would that do any difference?

Any help is greatly appreciated!
a b Ĉ ASUS
a b $ Windows 7
June 11, 2012 8:26:02 PM

AHCI must be enabled in BIOS before installing Windows, or the correct drivers will not be installed and cause problems if AHCI is enabled after installation. You should be able to achieve a clean install with Home Premium if you use the facility to delete and format all partitions at the 'Where do you want to Install Windows'/'Advanced Drive Options' screen.

(If you had any data on the drive you wanted to keep the drive can be converted back to MBR in Windows. http://www.sevenforums.com/tutorials/26203-convert-gpt-...)
m
0
l
April 4, 2013 2:30:20 PM

Try - Enable CSM in Bios, adds compatibilty support to the UEFI interface.
m
0
l
April 19, 2013 7:48:48 PM

i just did this in my k55, to get into it, is same on every machine, 'pc settings' (not the desktop one) then General>Advanced startup then hit restart then Troubleshoot>ADVANCED >UEFI firmware settings after it boots again go to BOOT tab and enable launch csm and then the Launch PXE option then go to 'save and exit' and save changes and exit

(contrary to belief you can hold DEL on restart and it will go to the BIOS)
so go back into bios and check the 'Launch csm' settings....if they reset to disabled do the following if not skip this next part

Security Tab>key management>clear all boot keys......then re enable and csm and pxe and save a restart....check it again, if disabled ....reinstall boot key same way as above. re-enable csm/pxe and try again

when you havce finally gotten the csm to stay enabled after restart...in the SECURITY tab you will see 'secure boot control' is no longer greyed out....disable it....save and restart and get back into bios now put your win7 disk in ....go to the 'save & exit' tab and 'Boot Override' for dvd drive

well done you have now said f*** you to windows 8 and stuck with the cool kids :p , message me with any problems
m
0
l
!