Windows 7 WMI repair (systeminfo does not work)

Hello,

I have suddenly lost my systeminfo in Windows 7 Professional 64bit. When I type systeminfo in the CMD, I get ERROR: Invalid access to memory location. Also if I try to see the computer specs, it says Processor: Not available, and Memory: Not available. Also trying the msinfo32, it says "can't collect information" and doesnt show any of the system info. I cannot pinpoint when exactly this problem started occuring, but these things used to work for me. How do I fix this problem?
3 answers Last reply
More about windows repair systeminfo work
  1. Perhaps the following hint could help
    I know it is not for your OS
    try it anyway:

    systeminfo and other commands not working in cmd


    http://episteme.arstechnica.com/eve/forums/a/tpc/f/12009443/m/2850931235


    http://forums.techguy.org/windows-xp/357760-cannot-run-system-info.html


    How to use System Information (MSINFO32) command-line tool switches


    http://support.microsoft.com/kb/300887

    Cheers..
  2. Thanks greenfield, but unfortunately these do not work for me. I tried searching for my problem everywhere, but couldn't find a matching case. :(
  3. Apts,

    Microsoft does have an official Windows 7 Support Forum located here http://social.technet.microsoft.com/Forums/en-US/category/w7itpro/ . It is supported by product specialists as well as engineers and support teams. You may want to also check the threads available there for additional assistance and guidance.

    In the meantime, have you performed a memory test to confirm that hardware isn't the issue here? Also, have you performed a virus scan to ensure that malicious software isn't the culprit either?

    Jessica
    Microsoft Windows Client Team
Ask a new question

Read More

Windows 7 Command Prompt Memory