Sign in with
Sign up | Sign in
Your question

Computer says unplugged

Last response: in Networking
Share
March 7, 2013 9:33:17 PM

So my computer keeps on saying
"A cable is not plugged into the network adapter 'Local Area Connection"
then it has a single box with
"Plug a cable into the network Adapter"
What gets me is that I did, and not just 1 cable, I spent 40 dollars and bought another cable (it just had to be 50ft long), and if the new one doesn't work than it must be the NIC right? So I went into the device manager and went into the properties of my NIC (Realtek RTL8139/810x Family Fast Ethernet NIC) and it says this device is working properly. I updated the drives and all and STILL no internet. I got a new router and ethernet cable so that can't be the problem, and windows vista says it has no problems so,
HELP

More about : computer unplugged

March 8, 2013 1:14:59 PM

An unidentified network can be a difficult issue and there are many things you can try.

I would start with some command prompt commands that can clear the problem (disconnect the network cable first) and then go through these commands -- you will want to use an elevated command prompt so click on Start button, enter Cmd in the Start search text box, and press Ctrl-Shift-Enter shortcut to run the command prompt as administrator, and allow the elevation request:

ipconfig /release
ipconfig /flushdns
netsh winsock reset
netsh int ip reset c:\resetlog.txt
netsh int reset all

after a few moments reattach your Ethernet cable and try to get an IP address with:
ipconfig /renew in the command prompt window.

Next try changing the registry toggle key that can be an issue in Vista as described HERE.

Some of the other things that are often successful in fixing it include deleting the Ethernet adapters and then re-installing the latest available driver, or upgrading the adapter driver from the device manager; right click on the adapter in network control panel and disable it, then re-enable it; Norton products can cause this, so try uninstalling them temporarily; disable IPv6 in the adapter control panel.
March 8, 2013 2:04:18 PM

Everything Realbeast said was right on the money, except he left out something important. The physical layer...

Just because a cable, or router, or NIC or any other component is new, doesn't necessarily mean it is working right...

So here is the series of questions...

#1. Did you test the router, cable etc.. with a known good working computer or LAN tester?
#2. Do you have a link light on both the router (or switch) and the NIC? What color is it?

Another thought.

You mention you are on Windows Vista, now I don't have a ton of experience with Vista, but I understand that it is similar enough to, and uses many of the same drivers as Windows 7...

Since this is a Realtek nic we are talking about, it IS possible that if you are using the Microsoft provided driver, that the driver itself is faulty. Try getting the latest driver from the NIC vendor, or Realtek. Remove the device through your device manager, and reinstall it using the vendor driver.

Like I said, it is possible that could be the issue. I know the 8169 Gigabit NIC driver doesn't work properly under Windows 7, and causes some connectivity problems (requires manual speed / duplex setting to get it working right). The problems go away using the Realtek provided driver...
Related resources
!