adding WD 180gb drive to system.

I'm currently trying to install a WD 180 gb hard drive onto a Gigabyte 8INXP motherboard. I hook up the drive to the Promise 20276 controller and use a newly created driver floopy for the controller, but it will not work. I get an error message that the program ULTRA.SYS is have problems with the Win2K install disk. I have downloaded the lastest driver from Gigabyte and still get the same message. What is going on??? I don't want to have to install and use the drive controller that came with the hard drive, since I have a Promise controller built into the motherboard.

Thanks.
8 answers Last reply
More about adding 180gb drive system
  1. ok I downloaded the manual for the MB you said you had. It looks like the RAID controller can be set up to be a second set of IDE connections. Also are you even sure you enabled the RAID controller?
    I'm not certain but maybe it needs to be set as RAID for controller function to be able to use the raid drivers. If set to ATA it may just be seen as another regular drive controller.

    Just to expidite things, the manual says its a part of "Intergrated Peripherals" of the BIOS.

    GK

    Don't mind me I'm just posting so it doesn't say I'm a newb.
  2. I think the guy doesn't need raid. He simply wants to install one single 180GB HD onto his mobo. Since most onboard IDE controller won't recognize such big drives, Promise raid/ide controller is needed.

    I suggest he checks the main bios and make sure the controller function is set as ATA instead of RAID. Also make sure the driver files are put in the correct path in the floppy.
  3. Considering the MB has a p4 Triton chipset and I would imagine it supports the Big Drive technology for larger than 138GB drives.

    GK

    Don't mind me I'm just posting so it doesn't say I'm a newb.
  4. Yes, I'm just trying to install the WD 180gb hard drive as just the only hard drive.
    The setting for the Promise controller is set to ATA and I've installed the files for the driver disc like they say I should in the "readme.txt" file for that controller.
    The exact error message is: "file \win2000\ultra.sys caused an unexpected error (18) at line 1211 in d:\nt\private\ntos\boot\setup\oemdisk.c."
    It tells me to Press any key to continue and when I do, the rest of the startup loading of Win2K continues and shows me that NO drive is hooked up, even tho the drive shows up when the controller inits as 167gb's.
    Another friend and I where talking about this, and he suggests that I try to load another OS onto it, I still have my WinNT install CD and was going to give that a try sometime soon, if this could not be figured out and then to upgrade the OS to Win2K.
  5. I have seen this (similar) error message before. That's when I tried to install Promise raid driver for my Win2000. It turned out that I didn't put the driver files in the correct paths in the floppy. Can you check your floppy again? What files and path have you got inside?
  6. I put all the files into the top level of the disc that the it said in the readme.txt file, should I put the files in the Win2K sub directory into another sub directory like the CD had them??? I looked in the Readme.txt file and I don't remember them saying that it had to be put into sub directories, but I will try that and see.

    We aim to please, but our aim ain't very good.
  7. That did the trick, I looked back onto the install CD and it said to copy the directory onto the disc, and I just thought that they ment to copy what was on that directory into the top level of that disc, silly me for thinking before reading. 8P

    Thanks everybody for you input and I'm much more happier now that I can finish moving over data onto that hard drive.

    LP.


    We aim to please, but our aim ain't very good.
  8. Glad to hear that you did it. :)
Ask a new question

Read More

Hard Drives Western Digital Controller Motherboards Storage