4g Stick limited connectivity

Hello,
I have had Clear for 2 years, and recently changed to netzero, both of which use the Wimax network.

I plugged in the Netzero 4G stick and it worked fine, once.

Since then, I plug it in, it receives full signal and green connection strength, but I get a "Limited connectivity" error and no internet access.

It worked 2 days ago, and I have installed no updates since.
1 answer Last reply
More about stick limited connectivity
  1. Things I have attempted so far:

    - I have turned off wifi

    - I have tried various USB ports

    - I have deleted the RNDIS from Device Manager and re-plugged in the stick, to let it reinstall.

    - I have hard-reset the 4g stick via the pen-hole on the device

    - I have power cycled my laptop by removing the battery and power for 20 minutes

    - I have confirmed that IP address and DNS server are set up to auto assign for IPv4.

    - ...posted on Toms Hardware?

    I am in the same area that Clear has worked for 2 years, and where Netzero worked the first time I used it. I have pinged 192.168.14.1 and the device is sending and receiving correctly.
Ask a new question

Read More

Connectivity 4G Limited Connectivity Wireless Networking