Sign in with
Sign up | Sign in
Your question

Intel Gigabit Network Connection keeping my PC from sleeping

Last response: in Windows 7
Share
June 14, 2012 12:51:29 AM

Ever since I built this PC (about 1 month ago now) I haven't been able to put him to sleep. I can set the "time until sleep" for 1 minute and sit next to him watching and waiting, and that works, but anything more than 5 minutes and he just won't sleep.

I did some digging and figured out how to use the Event Viewer and Command Prompt "Lastwake" command to find what's waking him up. It's my Intel 82579V Gigabit Network Connection. I imagine that means that he's getting signals from the internet while trying to sleep. I have Steam and MSN isntalled, but even when I log out of those and close them, the computer still won't sleep.

Now that I've figured out the source of the wake though I'm not sure what's the next step. I'd rather not have to unplug my internet every single time I want the computer to sleep. Aside for simple inconvenience I believe that would put some serious strain on the port over the long term (my last PC's LAN port was one of the first things to fail). So is there a setting that I can change so that the computer ignores the Network Connection's wake signals?

Thanks in advance to anyone who can help me.
a b $ Windows 7
June 14, 2012 12:56:53 AM

Hi :) 

Look in the Bios for LAN settings...

All the best Brett :) 
m
0
l
June 14, 2012 1:20:02 AM

Can't it be done from the control panel or the device manager? I get nervous when I have to go into the BIOS/UEFI.
m
0
l
Related resources
a b $ Windows 7
June 14, 2012 1:25:37 AM

PTNLemay said:
Can't it be done from the control panel or the device manager? I get nervous when I have to go into the BIOS/UEFI.



Hi :) 

No....

All the best Brett :) 
m
0
l
June 14, 2012 1:30:47 AM

I'm in the Asus UEFI now...

I see fan controls, system performance, boot priority, and a series of shortcuts. None of them seem to have to do with LAN though.
m
0
l
a b $ Windows 7
June 14, 2012 1:45:28 AM

Hi :) 

Look for..."wake up on lan"

All the best Brett :) 
m
0
l
June 14, 2012 1:46:31 AM

I think I found something in Device Manager. The Intel Gigabit Network Connection is listed under "Network Adapters". And in the properties I found the "Power Management", I think this is what I was looking for. There are power saver options and "Wake on LAN" options.

Now I don't want to start switching things off if some of these are important... a couple seem to be correctly placed, such as "Respond to ARP requests without waking system" and "Respond to NS requests without waking system". But in the Wake on LAN there are some that are on such as "Wake on Magic Packet" and "Wake on Magic Packet from power off state" and "Wake on Pattern Match".

I'm pretty sure one of those last three (if not all of them) are the root of the problem. For some reason my internet is spitting signals at my PC and the Intel thingy thinks I'm trying to remote-activate him. It actually sound pretty cool in principle... in combination with log-me-in or SplashTop it could be pretty powerful. But I don't like what it's doing right now.

Can anyone confirm for me that it's safe for me to shut these off? I'm not going to screw up my internet or anything?
m
0
l
!