IOmega harddrive not recognized by Windows 7

I am trying to fix a iOmega harddrive for a friend and the issue that he has is that the iOmega is not being recognized by his computer. The device has power, the disk is spinning and the led is on and stays constant, no flashing or anything. I have tried to see if the device was in Device Manager but it is not. The device is not being recognized by Windows 7 at all. No beeping noises when I plug it in or anything. I have tried multiple USB ports as well as other computers. The device just isn't being recognized. Any help would be much appreciated.
Thanks in advance.
1 answer Last reply
More about iomega harddrive recognized windows
  1. theflash262 said:
    I am trying to fix a iOmega harddrive for a friend and the issue that he has is that the iOmega is not being recognized by his computer. The device has power, the disk is spinning and the led is on and stays constant, no flashing or anything. I have tried to see if the device was in Device Manager but it is not. The device is not being recognized by Windows 7 at all. No beeping noises when I plug it in or anything. I have tried multiple USB ports as well as other computers. The device just isn't being recognized. Any help would be much appreciated.
    Thanks in advance.

    Not being recognized in multiple computers would indicate the drive is faulty or dead, unless iomega requires drivers for the device, or the USB cable you are using is faulty. Have you tried any diagnostic apps ?
    http://hddscan.com/
Ask a new question

Read More

Iomega Hard Drives Devices Windows 7