Solved

Can't unregister a dll

I have a dll file called 6to4v32.dll that is a trojan which my AV picked up. I can't delete it and I can't unregister it. When I go to unregister it through command prompt I type the following while being in the system32 directory:

regsvr32 /u 6to4v32.dll

I actually renamed it to 6to4v32-old.dll to try to get it to stop infecting my computer but didn't work

and It always returns the error LoadLibrary("6to4v32-old.dll")failed - Access is denied.

I am running as administrator. I've tried it as an admin on both the computer and the domain but no luck. I also have all the permissions yet still get the error. Any ideas? Thank you very much
8 answers Last reply Best Answer
More about unregister
  1. what os
  2. I somehow ended up in the W7 Security section I apologize, this is for XP.

    I have booted into safe mode now and tried to remove the .dll but now it says

    6to4v32-old.dll was loaded, but the DllUnregisterServer entry point was not found.

    This file can not be registered.

    googling around it says I need to use pview to remove the file
  3. if you were able to identify the virus with a scanner i can point you to removal instructions
  4. yes the exact name is 6to4v32.dll

    the scanner picked it up but will not remove it, if I try to delete it using the scanner it says access is denied. This is where I get stuck.
  5. Best answer
    maybe check out the removal steps used here
    http://www.bleepingcomputer.com/forums/topic245817.html
  6. ok i will thank you i appreciate your help
  7. Best answer selected by dell3100user.
Ask a new question

Read More

Security Computers Command Prompt DLL Windows 7