Sign in with
Sign up | Sign in
Your question

Matsushita SR-8583 DVD Drive won't come out of PIO

Last response: in Storage
Share
a b G Storage
March 19, 2003 3:05:44 AM

Just put together a (mostly) new system, but I salvaged the DVD-Drive (the problem drive), a Sony CD-RW, and a ZIP 100 ATAPI off of the old system. Everything is hooked up to a Shuttle AK38N with an Athlon XP1700+. Doesn't matter which channel I use for the DVD drive or whether it's the slave or master on a channel, it won't come out of PIO mode. If I put it on the same channel as the CD-RW, it puts them both into PIO mode so I am stuck putting my CD-RW on the same channel as my HDD amd keeping the DVD on the channel with the ZIP drive. The drive is recognized by the BIOS and during the boot-up as being in DMA mode, but Windows XP just doesn't see it that way. The only way I can make it run in DMA is if I uninstall the IDE channel from the Control Panel , shut down the system, hook up the DVD and restart the system. When Windows reinstalls the drivers for the IDE channel and I set it 'DMA if available' it puts the DVD into Ultra DMA Mode 2 (along with the CD-RW on the same channel), but it switches back to PIO mode as soon as I reboot. There are no drivers or firmware upgrades that I could find. Replace the drive? Any ideas?
-Brett
March 19, 2003 3:50:20 AM

It can be lots of things... ive had issues with my pioneer dropping out of udma mode on random occasions.

New IDE cables may help, cable reseating, reinstall chipset drivers, reinstall drives etc
I also deleted and reinstalled the primary and secondary ide channels themselves which occasionally fixed the problem.

also, what PSU do you have... there is a far out possibility that a poor psu could be cauzing the dvd to have problems and thus run at pio speeds as a precautionary measure... bit of a long shot though.

P.S. dont run anything with the ZIP drive... they are known to cauze PIO'ing with other drives.

If nothing else works, replace the drive. Liteon 16x DVD units are cheap and good.

<b>Paying for Sex didn’t mean you couldn’t get it any other way – it meant that you could afford the convenience option, same as any other service.</b>
a b G Storage
March 19, 2003 4:03:32 AM

Thanks for the quick response. I've tried all sorts of different cables (ATA 33, 100, 133), reinstalling the chipset drivers, uninstalling the IDE controllers, no good. Sounds like I need a new drive unless someone can come up with something else. Thanks again.
-Brett
Related resources
March 19, 2003 4:09:48 AM

Have you tried 'massaging' it with a hammer yet? :smile:

<b>Paying for Sex didn’t mean you couldn’t get it any other way – it meant that you could afford the convenience option, same as any other service.</b>
March 19, 2003 7:39:18 AM

SR-8583 was released 4 years ago. Are you sure it can run in DMA mode? Did Windows on your old system show that it runs in DMA too?
!