Promise Ultra 100 TX2 Controller Card for WD 80GB

I just bought a Promise Ultra 100 TX2 Controller Card for my WD 80GB hard drive. Before I installed the card, I can at least see 32 GB out of 80 GB, but now all I can see is ONLY 2GB... aye....
What is just happened?
Please help me out... Thank you

p.s. I am using WinXP
9 answers Last reply
More about promise ultra controller card 80gb
  1. I'm using the same card, same drive, same settup! How about that. My guess is the thing is formatted to the wrong partition size, repartition it.

    <font color=blue>Watts mean squat if you don't have quality!</font color=blue>
  2. I see the 2GB space in the Windows XP OS. After I put in the card, Windows XP recognize the card along with the drivers with no problem. I've checked the hardware setting and the card is shown under SCSI section. I can see the Controller Card BIOS is shown as version 2.20.0.14. However, the disk came with the box is the older version so I went to the web site and download another BIOS which is 2.20.0.14 also.

    When I use Fdisk to check my 80GB HD, all I see is the 2GB with 100% usage. What a shock! I even went into Windows XP and reformat the HD but it still shown as 2GB.

    Please assist me further as soon as possible.
    Thank you
  3. In fdisk, delete that 2GB partition, then make a new partition. It should make that new partition full sized.

    <font color=blue>Watts mean squat if you don't have quality!</font color=blue>
  4. Oh, what I said assumes your version of fdisk is new enough, the version that came with Windows 98SE was new enough, anything newer than that should be too.

    <font color=blue>Watts mean squat if you don't have quality!</font color=blue>
  5. I've tried to fdisk but it's just hanging there and not doing anything...
    Basically, I have two drives. The C is 20GB which is recognized no problem in XP and DOS. However, when I went into the fdisk and click 5 try to change the current drive to my G (80GB one), all I see the the black screen with a scentense "Change current Active Drive". Then, it just sit there forever...
    What should I do now?

    p.s. what if I want to do ALL on my computer over...Will that help?
    I mean a fresh start with the BIOS too not just the XP...

    HELP HELP HELP...I am so frustracted.....
    Thank you
  6. Here are the steps I went through:
    Under DOS,
    Yes to "Do you wish to enable large disk support?"
    Select 4, "Display partition information (This is my C drive)
    Partion: 1
    Status: A
    Type: NTFS
    Mbytes: 19085
    Usage: 100%

    Select 5, "Change Current Fixed Disk Drive"
    Disk Mbytes Free Usage
    1 19093 8 100%
    2 32252 30240 6%

    Then, 2 to enter fixed disk drive
    After all that,
    Select 3, "Delete partition or logical DOS drive"

    Then, I reboot to get into XP.
    All I saw under Disk Managerment is still only 1.96GB unallocated..
    So, I went ahead right click to create a "new partition".
    After the process, I still see this HD shown as 1.96 GB Health....

    What is wrong with my steps?

    Please help....
    THANK YOU SO MUCH
  7. It sound's like you're using an old version of DOS boot disk with only Fat 16 support. Try downloading a later boot disk from www.bootdisk.com, I suggest the 98SE bootdisk.

    <font color=blue>Watts mean squat if you don't have quality!</font color=blue>
  8. I've download the Win98SE boot disk that you mentioned but XP still not recognize 80GB...
    Under Fdisk, I can see the HD only for 32GB but it decrease to only 2GB in XP inside the Disk management...
    Any more ideas?
  9. The drive might have a jumper setting to limit the size to 32GB for compliance with older controllers. I think mine does, if I'm not mistaken. You should check the jumper settings on the drive against the jumper diagram on the lid.

    <font color=blue>Watts mean squat if you don't have quality!</font color=blue>
Ask a new question

Read More

Hard Drives Western Digital Controller Storage