How do I use Foobar2000 and Teamspeak at the same time?

Howdy, Im an audiophile and Im growing tired of not being able to use Foobar2000 with 96k audio through my dac and amplifier at the same time I chat on TS. Team speak glitches out and fails to provide any audio of any type of Foobar starts running before or after I log into Teamspeak3.

I use my Dac as my source out and its selected in both Foobar and TS, is there a way to get both to go through the same output without screwing with each other? Any help is appreciated.
9 answers Last reply
More about foobar2000 teamspeak time
  1. Do you have an option to try different audio plugins(output) for foobar?

    What kind of sound card do you use and what are you listening to in foobar2000?

    Teamspeak 3 also has 2 audio options to try.

    Direct Sound or Windows Audio Session, see if one works right(just in case auto does not work right).

    Does TS affect other programs or is it just foobar and does foobar effect other programs. I have never had this, but I am not set a 96k either(I have no audio source that good. well outside of bluray movies).
  2. Yes, many plugin and output choices. I use Wasapis plugin for the best audio quality possible, if I change any settings on TS beyond default, it just freezes up, chat lights stop blinking and no audio is emitted, nobody can hear me as well.

    No sound card, a USB Dac which is selectable in foobar and TS as my output

    Neither option works on TS, it freezes up if its not set to auto

    Nothing else uses plugins like foobar or can achieve higher sampling rates that I use so i am unable to test it on anything else :[
  3. The only thing I can think of is to try lowering the sample rate, I know it sucks, but maybe USB is somehow holding you back.

    Would be worth a try just for testing.

    Windows 7's(if thats what you are on) built in audio setup is strange, but generally very forgiving(even letting on switch sound cards without even crashing the program playing sound).
  4. This hasn't been solved, I never found out what is causing problems. When I start Foobar and play a song, then run Teamspeak3, the mic and audio do not transmit from the get go. When I start TS first and hear people chatting and everything working fine, then run Foobar, the mic and audio stop working and foobar plays normally.

    I cannot lower the sampling rate in Foobar below sadistically low levels. The lowest it goes is 8K and nothing will play at that level. Im I truly the only audiophile in the entire world who wants to listen to music in the background but also have the ability to use Team speak freely? Other music programs work just fine, I can hear youtube videos on the net and TS at the same time through the same USB sound card I use...why the hell Foobar isn't working is beyond me.
  5. You got me.

    So down to 44.1k does not even work even with another audio out plugin?

    Can you give me a link to the plugin you use if it is external(or does the player have it?). I would like to try it out.
  6. Im far from an expert but if im not mistaken when you have the Wasapi plugin runing it'll always prevent sounds from every other apps. Try using your dac/amp normally rather then through wasapi and it should work fine.
  7. Good point, can that plugin(WASAPI) turn OFF exclusive mode?

    With exclusive mode off, other audio streams should still work.
  8. Yeah the plugin can be turned off easily in the output settings. I could never hear any other sound with WASAPI on and had to close Foobar and restart the app before i could hear something. I just choose my amp without WASAPI as the output and i can hear every sound from game, web browser and so on.

    And i find the idea of trying to get the highest possible music quality incredibly stupid when we're talking about background music but heh, whatever he fancies i guess.
  9. Uhh, I game while I chat. And while I game, I listen to music. Millions of gamers do it.
Ask a new question

Read More

Configuration Audio Windows 7