Sign in with
Sign up | Sign in
Your question

Resetting security settins on a hard drive

Last response: in Windows 7
Share
June 24, 2012 4:23:18 PM

I've messed up the security settings on one of my drives such that I can't encrypt any file or folder on that drive.

I get a message saying "you will need to provide administrator permission". This is even though I am the administrator and I have ownership and control of the drive and the folders and files on it. Weird, right?

Is there any way to reset the permission on a drive short of formatting it?

More about : resetting security settins hard drive

June 24, 2012 4:46:49 PM

Try taking ownership of the drive or folder under properties>>security>>advanced>>owner>>edit click on your name and click apply.
m
0
l
June 24, 2012 9:33:40 PM

I already have ownership of the drive and all of the folders and files on it. That's what's weird.

I don't know if it's related, but I can't grant myself "special permissions".
m
0
l
Related resources
June 25, 2012 1:38:14 AM

Try seeing if your account is in the local administrators group in computer management.
m
0
l
June 25, 2012 1:42:17 AM

mightymaxio said:
Try seeing if your account is in the local administrators group in computer management.


It's in the Administrators Group under Computer Management (Local)--System Tools--Local Users and Groups--Groups.
m
0
l
June 25, 2012 2:25:12 AM

Do you by chance have UAC turned off?
m
0
l
June 25, 2012 3:01:50 AM

mightymaxio said:
Do you by chance have UAC turned off?


No, UAC is turned on.
m
0
l
June 25, 2012 3:39:17 PM

Couldn't figure it out so I reformatted the hard drive. I wish there were a logical guide out there that explains file security settings.
m
0
l
!