Sign in with
Sign up | Sign in
Your question

Intel Application Accelerator and UDMA mode

Last response: in Storage
Share
April 23, 2003 5:32:50 PM

This might be a stupid question, but how do I ensure that UDMA mode is enabled on my hard drives with Intel Application Accelerator 2.3 installed? Or does IAA automatically enable this feature? I've tried to find the "Advanced" tab in the properties of my hard drives and IDE controllers within the Hardware Manager and System Properties, but the tab isn't present.

I ran Sisoftware's Sandra program, and it benchmarked my hard drives as being extremely slow when compared to computers in its database with similar specs; like 1/5 as fast as the others. I'm trying to see why it's so slow, if Sandra's benchmark is even reliable.

Thanks for any info!
April 23, 2003 5:48:37 PM

In 2k and XP the UDMA settings should be in the primary and secondry IDE controllers, in 9x they are on the drive properties.

I've always had best results with master/slave configurations than with cable select... so you might like to re-jumper your drives, if you haven't already.

If you are not seeing the settings or if they are greyed out, it might be because you do not have UDMA enabled in your BIOS (some default to off, others to on). Some BIOSs (noteably on Gigabyte's boards) have a specific entry for "Enhance IDE performance" and won't enable UDMA until that is turned on.
If your BIOS has a specific function to detect IDE devices, you should use that and then check the Standard CMOS screen to be sure the UDMA is enabled. Other BIOSs detect drives by marking the first field on the line in Standard CMOS and pressing ENTER. Of course you can manually turn on UDMA if you are sure everything else is right.

Generally, once you have UDMA working in the BIOS, the advanced tabs should appear in 2k or XP's IDE controller settings or the DMA box should no longer be greyed out on 9x. If you are using IDE drivers other than the windows default ones, you may have to reinstall the drivers to get access to the settings.

There is one other thing that will prevent UDMA from being enabled... drive cables. Most BIOSs will do a test to see if it can be enabled... if you have the older 40 wire cables or if you have damaged 80wire cables, UDMA is turned off to prevent data corruption. FWIW... I always use 80 wire cables and I replace them after 3 or 4 turns of being unplugged and plugged back in to ensure they are always in top condition. The new 80 wire cables aren't really all that sturdy.

Hope this helps...




--->It ain't better if it don't work<---
April 23, 2003 6:13:17 PM

Ah, thanks. I am using Windows XP. My motherboard is an Asus P4T533, and I'm using Antec Cobra (I think...some kind of snake!) rounded ATA133-rated IDE cables, and my 2 hard drives are configured as master and slave by jumper.

So, even with Intel Application Accelerator installed I should see DMA listed on the IDE controller's properties if UDMA is selected in the BIOS hard drive config? I'll have to check my BIOS; I know I have the hard drive detection set to "Auto", but I'm not sure if UDMA is being used.

I know Intel Application Accelerator includes window that shows hard drive properties, and shows the Current Transfer Mode of both my hard drives being "UDMA-5". However, there are no options in the Hardware Manager to enable or disable UDMA, and some options are greyed out; therefore I assumed Intel Application Accelerator automatically took care of the settings.
Related resources
April 23, 2003 6:44:44 PM

Ok, one more suggestion...
If taking the drives off AUTO in your BIOS doesn't get it, try uninstalling the Intel tool and see what happens in the hardware list... You won't be the first to have problems with these "helper" tools, especially in XP.

A couple of other things to consider (you seem fairly savvy so you may have already been over this... but just in case...)

If the drives are badly fragmented or scattered (contiguous files but not in any special places) your drive performance can suffer horridly as the seek time inhibits your throughput. You may benefit by putting your drives through an advanced defrag/consolidation tool like O&O Defrag or Perfect Disk. Sorting your hard disk by name or date can greatly improve performance.

O&O's site is here:
<A HREF="http://www.oo-software.com/english/products/oodefragv4/..." target="_new">http://www.oo-software.com/english/products/oodefragv4/...;/A>

I've been using O&O for about a year now and there has been none of the over-time degradation in my drive performance. (ata100 averaging 30mb/s on ntfs)

Another real speed killer is the NTFS "Last Access" feature that has to go to the directory and update it everytime a read operation occurs. You can turn this off in the registry...

<font color=green>Hkey_local_machine\system\currentcontrolset\control\filesystem</font color=green>

Create or edit the Dword tag "NtfsDisableLastAccessUpdate" so it's value is 1

This is usually good for about a 15% increase in throughput especially on systems with lots of smaller files.


If you would like to test with a different benchmarking program, Give Fresh Diagnose a try:
<A HREF="http://www.freshdevices.com/freshdiag.html" target="_new">http://www.freshdevices.com/freshdiag.html&lt;/A>



--->It ain't better if it don't work<---
!