Sign in with
Sign up | Sign in
Your question

Can i play call of duty black ops 2 in window 8

Last response: in Windows 8
Share
March 4, 2013 9:38:03 AM

Hello,
March 4, 2013 9:59:44 AM

Yes you can. Steam and BOII works without issue for me on W8 Pro 64bit.
m
0
l
March 4, 2013 10:10:18 AM

As long as your computer is powerful enough, yes you can run BO2 on Windows 8.
m
0
l
Related resources
March 4, 2013 10:15:43 AM

With the minimum requirements, yes.
m
0
l
June 9, 2014 11:31:30 AM

I have problems with Call of Duty: Black Ops II as well. My OS is Windows 8.1 64 Bit and I'm so disappointed because I cannot play it. Here is what mine is doing:

I load the game, then when I'm in the lobby I would get about 60 FPS, sometimes and rarely 61 FPS. It's always 58~60 FPS
I would look for a match and then the map and textures and stuff would load, but it takes about 30 Seconds before I can actually play.. Now that I'm in game I still get around 58~60 FPS and then about 10 to 15 minutes later my game would freeze but I can alt+ctrl+Del out of there fortunately. When the game does crash the audio remains and replays... I decided to tweak with the settings a little bit and went to the "advanced" option.

I decided to turn some things on and some things off to see if it improved my FPS, turning off the Sync did do that.
In the lobby I would get about 59~63 FPS and then in games I would get over 100FPS. Which I'm like, "Oh this is good, maybe it won't crash this time.." unfortunately it did and it crashed earlier than the 60FPS did. It crashed within 3 to 5 Minutes of playtime... :\ Still crashes. I've been working for a solution for this game (because I love it) for over 6 Months and NO solution

Specs:
OS - Windows 8.1
CPU - AMD FX-8350 Eight-core processor
GPU - AMD Radeon HD 7770 1gb GDDR5
Harddrive - 1TB
RAM - 8 GB
PSU - 500w
m
0
l
June 18, 2014 6:26:25 PM

Did you try compatibility mode? The launcher file > properties> Compatibility> turn on compatibility Windows 7
m
0
l
June 18, 2014 8:26:32 PM

fooball said:
Did you try compatibility mode? The launcher file > properties> Compatibility> turn on compatibility Windows 7


Yeah I already have tried doing that. Unfortunately, it doesn't work that way either. I also ran the compatibility troubleshooter to see if anything helped. I got to a part where if I kept running as administrator and then that box pops up giving me permission. When I clicked "Ok", the box kept popping up everytime. The Compatibility Troubleshooter doesn't seem to give me much help.

m
0
l
!