Sign in with
Sign up | Sign in
Your question

Can't enable DMA

Last response: in Storage
Share
April 28, 2003 1:03:24 AM

I just built a new computer and once everything was up a running it didn't seem quite fast enough. I checked a few things and found that DMA was not enabled. Device Manager is set to "DMA if available" but it is stuck in PIO mode. Microsoft's site suggested to set "PIO only" then restarting then setting it in "DMA if available" then restarting. This did not work. I'm using a Quantum Fireball 40 gig and an Asus A7N8X mobo. I'm not using the Nforce2 IDE drivers because the system would not boot with them installed so I'm using the standard Windows IDE drivers. The hard drive worked fine with my old motherboard (Iwill KK266). Thanks

Asus A7N8X Deluxe
Athlon XP 2100+
Radeon 9700 pro
2x Crucial 256 PC2700
Onboard sound
Quantum Fireball Plus AS40
Windows XP Pro SP1

More about : enable dma

April 28, 2003 2:21:51 AM

This may be something that Microshaft will have to address in service pack 2, somehow you need to get the M/Bs drivers loaded because this technology is newer than WinXP, other people are bound to be running into this problem, have you checked ASUS to see if theres a patch or BIOS update that addresses this issue, I can already tell you if its a Microshaft problem they'll probably charge you for the patch from them, unless you wait for service pack 2. How is your system configured, whats on the primary and secondary IDE?

<b><font color=purple>Details, Details, Its all in the Details, If you need help, Don't leave out the Details.</font color=purple></b>
April 28, 2003 3:03:22 AM

Are your bios settings set correctly?



To err is human... to really screw things up you need a computer!
Related resources
Can't find your answer ? Ask !
April 28, 2003 3:37:54 AM

I have the HDD I listed before and an old Seagate on the primary and a HP 9150 CD-writer (master) and a LG DVD (slave) on the secondary. Everything in DMA except main drive. I've changed the IDE cables and removed the second hard drive. I have all the latest drivers and BIOS from Asus. I looked through BIOS and did not see anything that looked it would make a difference. Any suggestions on what to look for? I read a good post about this on another site and the overall conclusion was that it is that must be addressed in SP2. I don't feel like waiting that long so I'll keep trying.
April 28, 2003 4:29:21 AM

Trying to remember... Does your BIOS have a setting for "Enhance IDE performance" or something similar? If so enable it and go into Standard CMOS and re-detect your hard drives then make sure UDMA is enabled.

Also, this could be a cable problem. On most ATA100 or better mobos, the POST does a cable check to make sure you get reliable data transfer. If the cable check fails it will leave you in pio mode 3 or 4. A failure can be caused by several things... older 40 wire cables, cables in bad condition, cables too long, cables not correctly seated in the connectors, cables folded back on themselves, etc.. Also, the new 80wire cables are not very sturdy and most are only good for 3 or 4 plug-unplug cycles before the connections start breaking down... so you might want to try this with new cables.



--->It ain't better if it don't work<---
April 29, 2003 12:46:43 AM

Problem found and I feel stupid. After three days and checking a few hundred things I finally decided to examine the hard drive itself. Guess what, one pin short. A pin near the middle had been pushed in and was just barely visible. I pulled it out with pliers and carefully reconnected. When I started up it was still in PIO but I set it to PIO only rebooted, set it in DMA if Available rebooted, and there it was Ultra DMA Mode 5. I've had this drive in three systems and must have installed/uninstalled it a couple dozen times. Guess I was not careful enough. Thanks for the help.
!