Sign in with
Sign up | Sign in
Your question

SATA to IDE converter

Last response: in Storage
Share
May 5, 2003 3:07:05 AM

I just bought a WD Raptor 10k SATA HD and a generic i2s converter. I can't get the hd to register in the bios (even tried fdisk anyway). :(  I got an STAT instead of a PATA because I'm planing on upgrading my mobo soon, but I need a HD now.
I have a Asus P4T533 (Intel 850E chipset), 2.26 P4, & 2x256 PC4200. The mobo was one of the original releases and I still have the stock bios (I will try the new asus 1006.bin bios version next, but it doesnt say anything about fixes for IDEs). It has ata100 IDEs and ATA133 raid ports, but I dont see any raid options in bios. I tried hooking the HD to each and set the ata100/133 jumper on the i2s converter both ways for each.
The converter plugs directly into the mobo IDE port and the serial cable is single drive only (guess thats the way serial drives are). It has a 3.5" pwr connector that I did hook up.
The HD has 2 pwr connectors (regular 4pin from PS & a serial pwr connector), but it says on it not to use both. I tried the reg 4pin and tried using the serial pwr one w/ an adapter.
Ive checked all the connections but didn't mess w/ the drive jumpers too much cause they appear to only be for power managment.
Im thinking its probably the generic i2s converter or maybe I need a bios update, but its possible I could be boneheading something :p . Any ideas?

More about : sata ide converter

May 6, 2003 3:42:08 PM

I am using the raptor but on a sata inteface.
I think you may have problems with jumper settings. Are there any other drives on that ide chanel? If so I would remove them and put the raptor on the primary connector. The raptor does have jumpers but their use is unspecified. I would make sure that those are setup correctly. I assume you have tried the usual stuff like switching cables and power connections, making sure the drive is powered. checking the ps etc...




To err is human... to really screw things up you need a computer!
May 7, 2003 6:15:15 AM

That adapter is made to use serial drives on IDE adapters? I've only heard of adapters to use IDE drives on serial adapters. And I don't think those would work in reverse.

<font color=blue>Watts mean squat if you don't have quality!</font color=blue>
Related resources
May 7, 2003 10:14:03 PM

I agree with Crashman...I think you need a PCI SATA controller, because the converters are to use PATA drives on SATA controller, and not SATA drives on PATA controllers.

__________________________________________________
It's not important to know all the answers, as long as you know how to contact someone who does.
May 8, 2003 1:53:59 AM

Doh! :p 
*converts Parallel ATA devices to Serial ATA
bummer.
Thx for the tip. Guess Ill order a PCI SATA controller then.

Edit: I ordered a Silicon Image 3112 chip controller. I couldnt find the new 3512 chip card. :( 
May 13, 2003 5:03:25 AM

Ok, I got the controller, hooked it up w/ the HD, and installed the drivers, but it doesnt have a DOS driver so im stumped on fdisk'n it.
Is there a windows fdisk program available for this or another way around it?
Thx in advance.
May 13, 2003 6:39:14 AM

Hmm, fdisk has always worked for me on any card that has BIOS...

<font color=blue>Watts mean squat if you don't have quality!</font color=blue>
May 14, 2003 11:14:06 PM

I guess the HD still isnt being recognized. The SATA Controller seems to be booting fine, it just didnt come w/ DOS drivers.
Im woundering if I need a SATA cable. The one Im using is a single female/female one that came w/ the I2S converter. Does the SATA cable have to have master & slave connectors?
Thanks for your help Crash!
May 15, 2003 2:37:09 AM

Like I said, Fdisk has worked on every controller I've tried, no drivers needed. If the controller has BIOS it should force the drive to take a letter which is recognized by Fdisk, at least that works if it's the primary controller on the system (aka, the second boot device with the floppy as first boot device). You probably need to set the BIOS to boot off floppy, then SCSI (PCI IDE controllers are treated as SCSI by BIOS).

<font color=blue>Watts mean squat if you don't have quality!</font color=blue>
May 23, 2003 1:26:31 AM

Was out of town for a week. Thx again! I set scsi in the bios and put it after floppy. Now the drive is showing up on fdisk, but on fidsk startup it displays a blinking "Unable to access Drive 1" and when I try to create a primary partition it gets a "run-time error R6003 -integer divide by 0" that ends fdisk and puts me back at the DOS prompt.
I guess the single connection cable that came w/ my I2S converter chip seems to be standard after all so its probably not that.
I think the drive jumpers are only for power management and I have it set to the standard PM2 position.
I am going to email WD and see what they think next.
May 23, 2003 4:11:47 AM

It sounds like you're on the right track now, it's up to WD from here. Have you tried their disk diagnostics?

<font color=blue>Watts mean squat if you don't have quality!</font color=blue>
May 23, 2003 12:46:32 PM

I have the same controller (onboard) and the same harddisk (2 of them now) and they both work fine, even in DOS. You don't need drivers except in Windows. In DOS fdisk should work instantly but its much easier just to create the partition while installing Win2K/XP on the setup. I have a bad experience with converterboards though, I hope you aint using them anymore ;-)

Well if you still have any questions lemme know.
Greetz,
May 23, 2003 9:26:53 PM

What O/S are you trying to install? If it is 2000/XP, just boot from the CD and let the text mode setup handle all the Fdisk buisiness for you.

My computer is the leading cause of global warming.
May 25, 2003 4:11:04 PM

Finally got my head out of my ass and come up w/ some obvious ideas. :p 
Figured I could check my PCI SATA controller by using the I2S converter chip and a PATA HD and that worked fine.
I got to thinking about the power managment jumper and decided that sense its connected to a pci controller and not the mobo it probably didnt need power management enabled so I pulled the jumper and that worked! :) 
I did try pulling the jumper originally, but not after setting PCI-SCSI in the bios boot sequence. I seem to always take forever to figure out simple [-peep-] like that. :p  lol
!