Delayed write failed on Maxtor 60Gb

I'm having trouble with one of my harddrives. It keeps getting "Delayed write failed" errors. Over time the files corrupt until the point where I need to wipe and format.

I've run with the same config fine under ME, but had these problems when I upgraded to XP. Microsoft say to disable file caching on the drive, but it is on my 2nd raid channel (IDE 4 running in ATA133 mode), and file caching isn't an available option. There is no option in the BIOS to force fast writes. I have another 40GB Maxtor on my 1st RAID channel (my system disk), and it runs no worries. I'm just about out of ideas, so anyone else got some?

My setup:
P4 2.4GHz (42º load)
Gigabyte 8IHXP (i850E)
512Mb Samsung 1066Mhz RDRam
IDE 1: Master: Samsung 20Gb (boot) Slave: 100Mb ZIP
IDE 2: Master: IOMega CDRW Slave: Samsung DVD-Rom
IDE 3: ATA133 40Gb Maxtor (system)
IDE 4: ATA133 60Gb Maxtor (this is the problem)
Leadtek Ti4400 128Mb
WinXP Pro SP1
4 answers Last reply
More about delayed write failed maxtor 60gb
  1. The way you have your drives setup is alot like mine... All drives as masters, 2 opticals on the normal IDE channels and the 2 HDD on the raid controller.

    What i would do in your case is:
    1. Download and install the latest RAID drivers for the controller.
    2. Consider flashing the bios as well to a version of similar newness of the raid driver. (to avoid any mismatch issues)
    3. Download the Maxtor drive utility tools and check the drive out for any problems.
    4. Try swapping around the last two drives... if the problem follows the drive then its more likely a issue witht he drive. If the problem stays with that controller it could be a dodgey cable or ide channel.

    A question: Has this problem slowly developed over weeks/months? or has it suddenly appeared.


    <b>What to do when your GF is having her period? Anal Sex of course!</b> :evil:
    <A HREF="http://members.iinet.net.au/~lhgpoobaa/images" target="_new">http://members.iinet.net.au/~lhgpoobaa/images</A>
  2. Thanks for the help!

    The problem is odd, seems to come and go. It started as soon as I upgraded to XP, though...

    I'll check my RAID driver versions once I get home from work, but I think I have the latest (hadn't thought of that... d'oh!). Just noticed Gigabyte have a BIOS update, so I'll flash that tonight too, but doesn't seem to address the problem. Recently ran the Maxtor util over both drives, they came up OK.

    I really should have tried swapping them out before now, but I'm lazy :)
  3. Possibly some winXP/Driver bug. Swapping drives aint hard either, just switch over the cables :smile:

    <b>What to do when your GF is having her period? Anal Sex of course!</b> :evil:
    <A HREF="http://members.iinet.net.au/~lhgpoobaa/images" target="_new">http://members.iinet.net.au/~lhgpoobaa/images</A>
  4. Please let me know if you figure this out. Your system is identical to mine (2.4 ghz, 8IHXP, 2x60gb Maxtor in RAID 0 array), and I'm having somewhat similar problems (I've received the same error message, as well as a few other problems). So far I'm basically clueless.
Ask a new question

Read More

Hard Drives Maxtor Storage