Sign in with
Sign up | Sign in
Your question

Setup linksys wrt54g access point for 3g

Last response: in Wireless Networking
Share
March 8, 2013 9:40:10 AM

Hi

I am using 3G to access the internet on my PC. I have a 3G modem connected, and want to setup my Linksys WRT54GL router to enable wi-fi, so other devices can access the internet as well.

Any suggestions?
March 8, 2013 11:21:53 AM

You'll need to connect the router to your PC, WAN to LAN, and bridge the 3G and LAN connections on the PC.

[3g modem]<-- usb -->[pc](lan)<-- wire -->(wan)[router]
m
0
l
March 8, 2013 11:26:43 AM

It is possible to do what you want. First, please answer these questions.
1. I assume your desktop is running Windows. If so, what version?
2. Is the 3G modem internal or external to your desktop?
m
0
l
Related resources
March 8, 2013 4:39:57 PM

Running Windows 8 Pro & 3G modem is an external modem - K4305 USB 3G Modem.

I've tried to bridge the connections, but can't. I have tried sharing it, but makes no difference.

Here's the thing - I can't route the wireless connections through the internet gateway, because, for the life of me, I cannot seem to locate the address. Sounds stupid, but I'm completely blanked out on this.
m
0
l
March 8, 2013 4:44:18 PM

eibgrad said:
You'll need to connect the router to your PC, WAN to LAN, and bridge the 3G and LAN connections on the PC.

[3g modem]<-- usb -->[pc](lan)<-- wire -->(wan)[router]



I've tried that. BTW, my router does not have a WAN port - it has 4 LAN Ports, and one labeled INTERNET (also CAT5).
Anyways - can't bridge the connections.

Also, when I switch on the router, Windows take the ethernet connection as the default internet connection, and tries to access through the linksys, and even though the 3g modem is connected, I can't access the internet.
m
0
l
March 8, 2013 5:14:51 PM

Spiritwalker13 said:
I've tried that. BTW, my router does not have a WAN port - it has 4 LAN Ports, and one labeled INTERNET (also CAT5).
Anyways - can't bridge the connections.

Also, when I switch on the router, Windows take the ethernet connection as the default internet connection, and tries to access through the linksys, and even though the 3g modem is connected, I can't access the internet.


run, cmd, ipconfig that will get you your Default Gateway IP address

If you reset the router, it will have a default ip address of 192.168.1.1 (if a newer router)

Set your computer ip address to 192.163.1.3

Hook router ethernet port to computers ethernet port and open a web browser. type in the default ip address and you should be able to access the admin router page.

Once configured you will lose connection until you put your computer ip back to DHCP.

leave user name blank and use "admin" as the password
m
0
l
March 8, 2013 5:57:16 PM

Spiritwalker13 said:
Running Windows 8 Pro & 3G modem is an external modem - K4305 USB 3G Modem.

I've tried to bridge the connections, but can't. I have tried sharing it, but makes no difference.

Here's the thing - I can't route the wireless connections through the internet gateway, because, for the life of me, I cannot seem to locate the address. Sounds stupid, but I'm completely blanked out on this.


Since your 3G modem is a USB device, then all of the components should be connected just as eibgrad had shown in his post. The connection that he shows going into the router (WAN) is the same as your port that is labeled Internet. If you have everything connected like this, you are most of the way there. eibgrad did mention that you need to bridge connections, and I want to be sure that you have done this correctly. To bridge connections, first go to the Network and Sharing Center. Click on "Change Adapter Settings" in the left column. There you should see icons for your 3G modem and your ethernet. You need to highlight both of those icons. To do that, click on one of them, then ctrl-click on the other. Now they should both be highlighted. Right click on one of those icons. You should see an option for "Bridge Connections". Click on that. It will then take a minute or so for Windows to bridge those connections.

Once everything is connected, and you have finished bridging connections, then the only thing left to do is to make sure that the router is configured to function in access point mode, and if you do a hard reset on the router, it will default into that mode. If you then make a temporary connection with an ethernet cable between your computer and a LAN port on the router, you can put 192.168.1.1 in the URL bar of your web browser and then you will be taken to the configuration page for your router where you can set up wireless security, DHCP range, etc. Be sure to save your configuraton and switch your ethernet cable on the router back to the WAN (Internet) port when you are finished with configuration.
m
0
l
March 8, 2013 10:33:35 PM

Spiritwalker13 said:
I've tried that. BTW, my router does not have a WAN port - it has 4 LAN Ports, and one labeled INTERNET (also CAT5).
Anyways - can't bridge the connections.

Also, when I switch on the router, Windows take the ethernet connection as the default internet connection, and tries to access through the linksys, and even though the 3g modem is connected, I can't access the internet.


I actually did a mistake here. I forgot the PC is grabbing the one and only public IP. So you can't just bridge the connections (USB + ethernet), or else the DHCP request from the router's WAN port will fail to get the public IP. Instead, use ICS to bridge them.

Also make sure the router, ICS, and 3G are all using different networks. IIRC, since Windows 7, ICS uses 192.168.137.x, and most routers use 192.168.1.x, so a conflict is unlikely. But I don't know what the 3G connection might be using. ALL these networks need to be different or routing will not work properly.

Another configuration option is to use a simple bridge (iow, NOT use ICS) but disable/unbind TCP/IP on the 3G connection (yep, you heard right). Now that connection won’t issue a DHCP request, but instead only the router will, thus ensuring only one device ever requests the public IP. But now the PC itself doesn’t have internet access. To solve that problem, use either a wired or wireless network adapter on the PC to connect back to the router. The added benefit here is that now ALL the devices using the 3G network share the same LAN, even your PC! So you avoid problems of communicating between the PC and other devices for network discovery, file/printer sharing, etc.
m
0
l
!