Sign in with
Sign up | Sign in
Your question

DRAM timings question

Tags:
  • Memory
  • DRAM
  • BIOS
Last response: in Memory
Share
May 8, 2003 11:31:46 PM

I am finally putting together my first PC. I have 1 gig of Corsair 3200LL. When I am looking at the timings in the bios I have, and maybe I am getting confused because of the order in which the numbers are being displayed, but my BIOS default settings are:
CAS Latency Time: 2
Act to Precharge Delay: 5
RAS to CAS: 2
RAS Precharge: 2

I guess Im confused because when I read about the timmings they are always written out 2-2-2-6-T1. Would my setting as they are now be 2-5-2-2? Should I leave them as is or change them? Please advise.

Thanks

Beer is living proof that God loves us and wants us to be happy. -- Benjamin Franklin

More about : dram timings question

May 9, 2003 1:46:22 PM

Your settings would be 2-2-2-5.


You can drop the RAS Precharge down to 1 cycle if you like. What board do you have that DDR400 on? What speed is the memory running at? And what is the FSB set at?



Depending on your answers you might/could get some better performance out of the system.



<A HREF="http://www.millionmanlan.com/MMLDefault.asp" target="_new">Million Man LAN 2 is June 25-29, 2003 in Louisville Kentucky... Be there!</A>
May 9, 2003 2:11:05 PM

Abit IC7-G
FSB is at 200.

Having major problems installing XP. Just wondered if this could be a hangup.

Beer is living proof that God loves us and wants us to be happy. -- Benjamin Franklin
Related resources
May 9, 2003 2:30:22 PM

Do you already have an OS on the system? Or are you starting from scratch as a new system?



Anyway. You should be able to run the latencies at 2:2:2:6 and CMD=T2.

I will recommend that you run the tRDC, cycle time, or as you stated it "Act to Precharge Delay:" to 6 cycles. It will allow for much better stability. You caould get HDD errors if you set this too low. What happens is your memory tries to do a tRP before the original cell charge is back resulting in a error. Basically it is "ready, shoot, aim"




<A HREF="http://www.millionmanlan.com/MMLDefault.asp" target="_new">Million Man LAN 2 is June 25-29, 2003 in Louisville Kentucky... Be there!</A>
May 9, 2003 2:37:31 PM

I am guessing that you are using two 512MB sticks.


Have you also tested the sticks with memtest86 or are you shure that the sticks are good themselves?



<A HREF="http://www.millionmanlan.com/MMLDefault.asp" target="_new">Million Man LAN 2 is June 25-29, 2003 in Louisville Kentucky... Be there!</A>
May 9, 2003 2:43:37 PM

Canterwood motherboards are having problems with Low-Latency memory. Increase your memory timings a bit until stability is maintained.
May 9, 2003 4:32:29 PM

There's an known issue with the i875p chipsets and Corsair Low Latency memory. Change your memory timings to 2-3-3-6 and that should resolve your problem. I have the GA-8KNXP Motherboard and the Corsair TwinX1024-PC3200LL memory and I had the exact same problems you're describing until I switched my memory timings to 2-3-3-6.

Make that change and you should be running smoothly!
May 9, 2003 5:28:31 PM

You guys are correct and the real reasons for the problems with lower latencies is in the memory modules and the chipsets. The modules claim to be faster but if you look at settings like the CMD timings, they can't run at the most agressive settings either because of their makeup and or because of the chipsets interacting with the memory. Intel has been putting CMD = 2T and 4T as settings in the BIOS. A CMD setting of 4T is one hard penalty for random accesses. Gaming is one example where having a higher CMD setting will hurt.

Still try to keep tRP at 2. There isn't a huge need for a long delay for the RAS Precharge. However if the chipset gives you problems raise the latency settings.

Raising tRCD up to 3 could help if you are still experienceing problems.

CAS 2 to 2.5 should not matter. However as you read below you will see what Intel published reguarding the three main latency settings. (tCAS, tRCD, and tRP)


What CMD setting do you have your board set for?

(I <A HREF="http://www.abit.com.tw/abitweb/webjsp/english/mb_manual..." target="_new">can't download your manual</A> so I don't know all of the specific options for your board.)

as I said above, Intel did a series of tests on different memory makes and models which <A HREF="http://www.intel.com/technology/memory/ddr/valid/dram_r..." target="_new">you can see here</A>.

Notice that Corsair is not on the list. That doesn't mean that it won't work but just that they didn't test it and publish it.

One thing that you should do is look at the timings of the memory that they tested. The configurations are between 2.5-3-3 and 3-4-4.


Play around with your settings. Start with the worst like 3-3-3-6-4T and work your way down to 2-3-2-6-2T to see what it will run at.



<A HREF="http://www.millionmanlan.com/MMLDefault.asp" target="_new">Million Man LAN 2 is June 25-29, 2003 in Louisville Kentucky... Be there!</A>
May 9, 2003 5:31:13 PM

Also turn off interleaving for the time being. that can cause problems with the CMD setting. Just try to get you other latencies down first and then play around with bank interleaving and the correct CMD setting.




<A HREF="http://www.millionmanlan.com/MMLDefault.asp" target="_new">Million Man LAN 2 is June 25-29, 2003 in Louisville Kentucky... Be there!</A>
!