Sign in with
Sign up | Sign in
Your question

Windows 7/ Server 2008 Network Share request for alternate credentials

Last response: in Windows 7
Share
June 28, 2012 4:32:49 PM

Setup:

Active Directory - 2008

Share Server - 2008


Issue

I need to install programs on the run for people at the office.

Normally i would do: Start>Run>\\server\share and i would prompt me for credentials (old samba share)

However

I am moving files to our new windows 2008 share server but when i do the same: start>run>\\server\share it doesnt prompt me for credentials and just gives me the error "ACCESS DENIED" based on permissions.

I know the currently logged on user doesnt have permissions but i need the prompt for credentials so i can input my credentials

Any idea? Not sure if its an Active Directory group policy setting, a share server setting or a user machine setting

Thanks
a b $ Windows 7
June 28, 2012 5:37:35 PM

what happens if you try to browse to \\server\c$ or \\server\admin$
are you prompted
June 28, 2012 5:43:51 PM

net use * \\server\share password /user:WindowsDomain\username

Then you can access the files via the assigned drive letter.
Related resources
a b 8 Security
a b $ Windows 7
June 28, 2012 5:46:44 PM

Try to map a drive to it, and connect with alternate credentials.
June 28, 2012 5:47:52 PM

Yes it does prompt me when i go to \\share\D$
June 28, 2012 5:49:32 PM

Jim_L9 said:
net use * \\server\share password /user:WindowsDomain\username

Then you can access the files via the assigned drive letter.



Well i dont want to Map a drive because i am doing this on the fly

Example: someone needs a program installed, rather than mapping a drive i just need to access it at that moment
a b $ Windows 7
June 28, 2012 5:53:29 PM

1. local user password expired that you are trying to browse from?
2. check share permissions on the folder set share to everyone and change ntfs permissions on the folder, giving access to only the techs and admins.
June 28, 2012 7:16:25 PM

the great randini said:
1. local user password expired that you are trying to browse from?
2. check share permissions on the folder set share to everyone and change ntfs permissions on the folder, giving access to only the techs and admins.


1. Password not expired

2. I changed the permissions but this way everyone can have read access and it still doesnt prompt for credentials
a b $ Windows 7
June 28, 2012 7:29:56 PM



not if you change the ntfs permissions, i find that you have to change permissions from the server. rpd to server > start > administrative tools > computer manager
expand shared folders > shares > "the share your working on"
right click on "the share your working on" select properties.
share permissions tab = set to everyone
security set = domain admins and any other groups or users you want to have access

local users that you are going to browse from should not need any permissions since you should be prompted for credntials.

June 28, 2012 9:43:35 PM

the great randini said:
not if you change the ntfs permissions, i find that you have to change permissions from the server. rpd to server > start > administrative tools > computer manager
expand shared folders > shares > "the share your working on"
right click on "the share your working on" select properties.
share permissions tab = set to everyone
security set = domain admins and any other groups or users you want to have access

local users that you are going to browse from should not need any permissions since you should be prompted for credntials.


I did just that

I set "Share Permissions" to "Everyone" (Read)

I set "Security" to "the OU that should have access as well as admins"

However i login as a regular domain user to the pc and i am able to access the share
July 2, 2012 2:01:14 PM

Any other ideas?

My Share Permissions are:

IT (OU) - Full Access
Domain Users - Read Access


NTFS:

Authenticated Users - Everything except Full Control
System - Full Control
Domain Admins - Full Control
Local Users (not domain) - Read & Execute


Could this possibly be a UAC issue? I have disabled it on the Shared Server....

Thanks


July 3, 2012 9:19:53 PM

For anyone out there

This is what Fixed the issue

- Click Start
- Click Control Panel
- Click System and Maintenance
- Click Administrative Tools
- Double-Click Local Security Policy
- In the left pane, click the triangle next to Local Policy
- In the left pane, click Security Options
- In the right pane near the bottom, double-click "Network security: LAN
manager authentication level"
- Click the drop-down box, and click "Send LM & NTLM responses"
- Click OK
August 29, 2013 12:10:36 PM

I had a similar issue accessing the c$ share on a Windows 2008 R2 server (virtual machine) in a Workgroup environment.
for me, skyvette77 solution had to be modified to use "Send NTLMv2 response only".

The default install setting was Empty, and the admin account kept on getting locked whenever I accessed the share over the network. In my case, the local admin account had a different password than the account on the domain.

--------
For anyone out there

This is what Fixed the issue

- Click Start
- Click Control Panel
- Click System and Maintenance
- Click Administrative Tools
- Double-Click Local Security Policy
- In the left pane, click the triangle next to Local Policy
- In the left pane, click Security Options
- In the right pane near the bottom, double-click "Network security: LAN
manager authentication level"
- Click the drop-down box, and click "Send NTLMv2 response only"
- Click OK
!