Sign in with
Sign up | Sign in
Your question

WD HDD wont partition or format...

Last response: in Storage
Share
May 12, 2003 4:21:24 PM

Hello…I am trying to “install” one new Western Digital 80 Gb, 8 mb cache, 7200 RPM “SE” IDE Hard drive into my tower puter which uses an ABIT KR-7A mobo. I intend to install WIN XP Pro on that HD and intend to make a 40Gb WD 7200 RPM the secondary or slave to the 80 GB Primary or Master HD. I connected the 40 pin 80 wire connector to my ABIT KR7A IDE 1 and then connected my CD ROM and CDR (these are sharing the same cable) to IDE 2. The 80Gb SE WD HDD is connected to IDE1 on the mobo.

My puter does NOT see the WD 80GB HDD even when I use the jumper block on that HD to “single, or “cable select”, or “Master”. (I am unable to manually set the drive parameters in my BIOS altho at times the BIOS will show a 80 GB, LBA enabled, drive)

During POST the 80 Gb HDD is not shown meaning that the POST field shows “NO drive”, even though the WB drive should be shown as Primary Master. I have yet to partition and format the 80GB drive.

My BIOS on my ABIT mobo is dated 11/23/01. Im sure that CSEL is available on this mobo.

What am I doing wrong that I can correct in order to partition and format this drive?


I have never spent this much time installing a HDD that is still not operational.

I do not have a computer which can access the web or any applications.

Thank you

intricate@rocketmail.com
May 12, 2003 4:59:20 PM

Did your BIOS show the optical drives during POST? Have you tried to connect the 80GB HDD to IDE 2 to see if the BIOS could detect it? Similarly, have you tried to connect an optical drive to IDE 1 to see if it's working there? This would tell you whether the problem is in your new HDD.
May 12, 2003 6:19:47 PM

Ok... run the checklist...

Are the jumpers set right?
Is the drive spinning up?
Can you hear the heads reset to track 0?
Is the cable on the right way around at both ends?
Is the data cable damaged?
Is the power plug all the way in?
Did you try using the IDE detect function of your bios?
Does the drive work in a different machine?
Does a different drive work in your machine?

In particular, note that it is very easy to damage a drive cable. The new 80 wire cables are very fragile and can be damaged simply by pulling the plug off the drive. As a rule, I replace these cables every third time I yank on them.

Worst case, grab the disagnostics from the Western Digital website and give them a try. If they report problems, get the drive replaced under warranty. It's entirely possible the drive is DOA (Dead On Arrival).


---><font color=green>It ain't better if it don't work</font color=green><---
Related resources
May 12, 2003 7:06:39 PM

I am using a NEW cable that came with my WD HDD. Upon booting, the first POST screen says "No primary Drive (Master)" and then the 2nd POST screen SHOWS the drive. (Using LBA access here and AUTO detect). Have tried to do the manual change in the BIOS but do not know
what the drive parameters are as they are not shown on the WD HDD case. The WD INTSALL DRIVE program on the floppy indicates a drive error (code) BUT when the Lifeguard diagnostic which takes about 3 minutes is run, it shows NO errors and perfect drive condition. I used a WIN 98 floppy as my boot disc and was able to partition the drive but then I went to format the drive the format c: showed a 10 Gb drive and stopped formatting at 3%. Yes Ive tried the drive on IDE 2 and it shows the drive as secondary. The cable is seated and i havent really listened to the head spin tho it sounds as if is active based upon the sound of the drive bay area. Ive tried the jumper block on CSEL, SINGLE, and MASTER and this HDD was a retail boxed version from WB not the OEM verison. Please help-I am about ready to give up and reinstall the old 20 Gb IBM drive as a master.
Thank you.
May 12, 2003 7:42:49 PM

You might try putting the 2 CD-rom drives as primary and the Harddrive alone on the secondary IDE.

Grab the Ranish partition manager from [link]http://www.ranish.com/part[/link] and put it on your 98 disk and see if it shows up as the full size, and can be partitioned and formatted.

Sometimes motherboards do wierd things. If it works you can probably run it like that. Or at least if it will load up, and then switch them back.

You might also have a problem with the hardrive's Single setting. You said you have tried it as Master, but did you have the CD-rom on the cable with it? Or was it by itself set to Master when you tested?
May 12, 2003 7:53:39 PM

In your BIOS all you should have to do is highlight the first entry on the line where the drive should be (IDE0, primary master, for a windows boot device) and press enter. That should detect the drive and set it up automatically for you.

IF it detects in other locations, (i.e. as the slave on the primary) I'd be prone to suggest there is a jumper problem. I don't generally recommend cable select as this will make the location of the drive on your cable the primary determinant of master or slave. Using the explicit jumper settings is usually faster and more explicit.

If you can't get it going from the advice others and I have given, I can only suggest you may want to have the drive checked by a technician... This won't be the first WD drive I've seen that won't function as a master... so you may end up doing an RMA anyways.


---><font color=green>It ain't better if it don't work</font color=green><---
May 12, 2003 8:50:54 PM

It's possible that if you've used the WD Data LifeGuard Tools to check the disk for errors, you won't be able to use any other kind of application to partition or format the drive (such as FDISK) <i>except EZ-BIOS</i>, unless you remove it. Even if FDISK appears to partition the drive correctly, Windows will be unable to assign drive letters to the partitions, due to the way that EZ-BIOS writes the partition tables.

I'd initially try setting up the drive alone on the cable, without any kind of jumper, which should be the correct setting for a Master without a slave, according to the <A HREF="http://support.wdc.com/techinfo/general/jumpers.asp" target="_new">WD website</A>. Then use these <A HREF="http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std...*N*5BEg&p_lva=&p_faqid=824&p_created=1037384345&p_sp=cF9zcmNoPTEmcF9ncmlkc29ydD0mcF9yb3dfY250PTgmcF9zZWFyY2hfdGV4dD1SZW1vdmUgRVpCaW9zJnBfc2VhcmNoX3R5cGU9NCZwX3Byb2RfbHZsMT04JnBfcHJvZF9sdmwyPTY1JnBfY2F0X2x2bDE9fmFueX4mcF9zb3J0X2J5PWRmbHQmcF9wYWdlPTE*&p_li=" target="_new">instructions</A> to remove EZ-BIOS. Afterwards, it's also possible that you may find it necessary to update the BIOS for the disk to be identified correctly.

Once EZ-BIOS is removed, you should be able to partition the drive, if it isn't actually damaged in some way.

Be sure that the version of <A HREF="http://support.microsoft.com/default.aspx?scid=kb;EN-US;q263044" target="_new">FDISK</A> on your boot disk is the latest version, or the entire size of the drive won't be seen correctly.

Toey

<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=32..." target="_new"><font color=green>My System Rigs</font color=green></A>
___________________________________________

<A HREF="http://forums.btvillarin.com/" target="_new"><b><font color=purple>BTVILLARIN.com</font color=purple></b></A> - <i><font color=orange>Your Computer Questions Answered</font color=orange></i>
!