Sign in with
Sign up | Sign in
Your question
Solved

Catalyst control centre making life hell!

Last response: in Windows 7
Share
June 30, 2012 4:28:00 PM

hello everyone
i was having problems with ccc not opening so i reinstalled windows
it worked fine for few days
today i tried to install the latest 12.7 beta drivers
and i came till the screen where it asks custom or express install
after excepting it, the installer froze
i uninstalled ccc and tried to install 12.6 and that too froze at the same window
even using system restore also did not work
any suggestions ?
plz help iam facing a lot of flak for installing windows again and again
any help will be appreciated
thanks!
June 30, 2012 4:40:14 PM

run DRIVER SWEEPER to remove all the (tiny) files remaining of CCC. if that doesn't help then try to reset CMOS.
m
0
l
June 30, 2012 4:41:16 PM

did that and my mobo doesnt have cmos button!
m
0
l
Related resources

Best solution

a b $ Windows 7
June 30, 2012 4:42:52 PM

The best way to install CCC is to first remove the existing AMD drivers by running the uninstall utility. You can find this in the following way:

Control Panel -> Programs and Features -> AMD Catalyst Install Manager -> Change -> Express Uninstall all AMD software

You will then want to remove a few things that the uninstaller leaves behind. This includes the AMD folders in Program Files and Program Files (x86) if you have a 64 bit system. After that, remove the ATI folder in "C:\Users\<your username>\AppData\Local" and "C:\Users\<your username>\AppData\Roaming". Also check for those folders in Public and Default

Next, run Driver Sweeper to clean out the registry. Normally this isn't necessary if your original driver suite was of version 12.x but if you've previously had an 11.x version installed it is recommended. If you're having problems, run it anyway.

Finally, reboot and install the 12.7 beta drivers.
Share
a b $ Windows 7
June 30, 2012 4:43:09 PM

Can you please explain how resetting the motherboard's CMOS is going to fix some driver problem within windows?

xtreme5 said:
run DRIVER SWEEPER to remove all the (tiny) files remaining of CCC. if that doesn't help then try to reset CMOS.

m
0
l
June 30, 2012 4:43:43 PM

sir i have tried all this after reading many forums i need a new solution!
m
0
l
June 30, 2012 4:46:03 PM

sir i have just solved it!
its a problem with the installer
i installed 12.1 driver and then installed 12.7 and it worked like a charm
thanks all!
m
0
l
June 30, 2012 4:46:20 PM

Best answer selected by panwala95.
m
0
l
June 30, 2012 4:48:08 PM

nicely done.
m
0
l
!