Sign-in / Sign-up
Your question

GO AWAY PIO

Tags:
  • DVD Writers
  • UDMA
  • Burner
  • Storage
Last response: in Storage
May 20, 2003 3:48:39 AM

Hi all,
I've got a burner that's stuck in PIO mode =(
FYI: this is winxp with the latest updates & service packs


Here's my IDE setup:

IDE 1)
[master] WD1000 running udma mode 5
[slave] none
IDE 2)
[master] PX-W24,10A running in PIO (booooo)
[slave] some liteon dvd drive running in udma 2 (but doesn't it do PIO too cause your IDE channel goes at the speed of the slowest device?)


From what I understand the burner should be supported in DMA (ata 33 or something) and PIO seems makin' my burns go quite slow.

Any advice welcome, tnx in advance!

More about : pio

May 20, 2003 7:56:06 PM

Make sure DMA is enabled in Device Manager. Open up Device Manager and check your primary/secondary IDE busses, make sure "DMA if able" is selected.
May 20, 2003 7:59:01 PM

Yep everything has that setting, that's why i'm posting =).
From what I hear PIO uses a lot of CPU power, and most of my burns have not gone faster than ~16 =( Not that i'm expecting them to write at 24x, but writing a full image should eventually go faster than 16x
Related resources
May 21, 2003 3:54:58 AM

I kind of figured you'd already have the DMA stuff enabled. Seems to be the most common issue though so I tossed it out there.

Have you tried running the drive by itself on the Secondary bus? That's what I'd probably do next. Maybe someone else can offer better insight as to what the problem is.
a b G Storage
May 22, 2003 4:52:33 AM

Go into the control panel and remove the Secondary IDE channel. Most of the time this fixes the problem when it reinstalls in WinXP & 2000.
-Brett
May 23, 2003 6:05:26 PM

Tnx guys, I'll try both solutions, and report back in a bit. =)
May 23, 2003 7:16:30 PM

Nice guys, thanks a lot for the help, mucho appreciated!
smitbret's fix worked, removing the secondary channel from device manager and then rebooting.

/me buys you a beer!
a b G Storage
May 25, 2003 5:31:28 PM

You may have to repeat that on a rare occasion. Glad it worked that easily for ya. Just a weird glitch in WinXP & 2000, must be an NTFS thing.
-Brett
May 25, 2003 8:36:25 PM

Not so sure on that.
I only have one of many drives that is NTFS and it is not my windows partition =\
May 27, 2003 1:39:55 PM

windows xp IS NTFS so your windows partition must be NTFS
a b G Storage
May 30, 2003 3:51:18 PM

windows xp can run on either NTFS or FAT 32. You make the selection when you install XP whether to format to NTFS or leave at FAT 32.