Sign in with
Sign up | Sign in
Your question

Unable to join multiplayer on LAN WITHOUT FIREWALL

Last response: in Video Games
Share
Anonymous
November 9, 2004 5:39:51 PM

Archived from groups: microsoft.public.games.ageofkings (More info?)

Please, Please help me.
I have 2 PCs running Win98, Netgear 4 port hub. Both Pcs
have Ipx with all of the Netbui setting enabled, and TCP/IP
as well. Can play War Craft with no prob. either player can
host. My problem is with AOE/RoR. I can play single player
on either PC. Both can launch a multiplayer and the other
can SEE the game. When I attempt to join it gives error
"Unable to Join"

Please, please help.
Regards,
M.
Anonymous
November 9, 2004 10:51:32 PM

Archived from groups: microsoft.public.games.ageofkings (More info?)

Hi,

When LAN games don't connect, there are a few variables to consider, for
example check for a patch at: www.avault.com/pcrl/patches_list.asp?letter=a

1. Disconnect from the Internet by physically unplugging the cable or DSL
line, and then since there's no longer danger of outside attacks, turn off
your software firewall (Norton's, McAfee, Zone Alarm, Outpost, ICF,
etc.) as these firewalls could be blocking data to and from your system.

2. If you use a router, it could be blocking you as well:
Routers have built-in port blocking firewalls based on NAT technology.
DirectX games require that ports be open in order for the data packets
to be able to travel from one system to another. Here's How to Configure
a router for Multiplayer: http://mvps.org/nibblesnbits/PortRoute.html#howto

3. If Step 1 applies to you, but you want an alternative solution, pick up a cross-
over cable from your local supply shop to directly connect one computer to
the other on a 2 player LAN, especially if both computers are close together.

4. If you have multiple network adapters, the game might be using the wrong one
To verify this behavior, click Start / Control Panel / System / Hardware Tab
/ Device Manager, click the + next to Network Adapters, right click the adapter
which accesses the Internet, and "Disable" it from the right-click menu. If that
works, open Control Panel / Network Connections, click Advanced / Advance
Settings / click the LAN Connection and then the UP arrow to change it's priority
so it's at the top of the list. Test your Internet games to see if they work this way.

5. DirectX 9.0b may need to be installed on both systems:
http://download.microsoft.com/download/c/9/c/c9c8a1d4-7...

6. Universal PnP might need to be disabled in your router, or in Windows XP:
a) To enable or disable UPnP in XP, click Start / Run / type: services.msc
and you can then right-click Universal Plug and Play on the list to Start it.
b) Consult your router manual for the UPnP instructions for your model.

7. Network Adapter drivers may need to be updated on one or all machines.

8. You may need to specify the target IP using a game specific method.
Consult your game manual or readme file in the game directory. For MS
games: http://support.microsoft.com/default.aspx?scid=fh;EN-US;gmsnetw

9. You might be specifying the Public IP instead of the Private (LAN) IP.
To easily find the Public and Private IP numbers of the computer you
are using, visit: http://www.u.arizona.edu/~trw/games/nat_or_not.php

For more in depth troubleshooting, try this MS Network Troubleshooting article:
http://www.microsoft.com/windowsxp/expertzone/columns/r...

--
Cheers, Windows XP MVP Shell / User
Jimmy S. http://mvp.support.microsoft.com

Game FAQs: http://support.microsoft.com/default.aspx?scid=FH;[LN];gms
Visit my Zone.com / Gaming Helpsite: http://nibblesnbits.tk or Call / Contact
MS Support at: http://support.microsoft.com/default.aspx?scid=sz;en-us;top
My advice is donated "AS IS" without warranty; nor do I confer any rights.
_________________________________________________________



"Aaarrrrrrrrrgggggggggg" <anonymous@discussions.microsoft.com> wrote in message news:556101c4c6ad$06612c50$a301280a@phx.gbl...
> Please, Please help me.
> I have 2 PCs running Win98, Netgear 4 port hub. Both Pcs
> have Ipx with all of the Netbui setting enabled, and TCP/IP
> as well. Can play War Craft with no prob. either player can
> host. My problem is with AOE/RoR. I can play single player
> on either PC. Both can launch a multiplayer and the other
> can SEE the game. When I attempt to join it gives error
> "Unable to Join"
>
> Please, please help.
> Regards,
> M.
Anonymous
November 10, 2004 1:16:13 PM

Archived from groups: microsoft.public.games.ageofkings (More info?)

Hey Jimmy,
Thanks for the response. I reviewed all of your input and
I have either already done this or it doesn't apply to this
setup as the PC's aren't connected to the internet and
don't have any AV software installed.
I'm at my wits end on this one. I've installed the latest
patch for AoE. The Hub doesn't have a firewall, I
reinstalled DirectX, and there is only one network card on
each pc. I have tried all of the different connection
options in the game regarding using IPX - Tcp/ip - Direct
Cable - Arrrrgggggggg.
I remember having this problem a year or so ago when we
were playing before. I have since formated one of the PC's.
I remember there was one specific thing I had to do but I
can't remember.
Thanks again for your input.


>-----Original Message-----
>Hi,
>
>When LAN games don't connect, there are a few variables to
consider, for
>example check for a patch at:
www.avault.com/pcrl/patches_list.asp?letter=a
>
>1. Disconnect from the Internet by physically unplugging
the cable or DSL
> line, and then since there's no longer danger of
outside attacks, turn off
> your software firewall (Norton's, McAfee, Zone Alarm,
Outpost, ICF,
> etc.) as these firewalls could be blocking data to
and from your system.
>
>2. If you use a router, it could be blocking you as well:
> Routers have built-in port blocking firewalls based
on NAT technology.
> DirectX games require that ports be open in order for
the data packets
> to be able to travel from one system to another.
Here's How to Configure
> a router for Multiplayer:
http://mvps.org/nibblesnbits/PortRoute.html#howto
>
>3. If Step 1 applies to you, but you want an alternative
solution, pick up a cross-
> over cable from your local supply shop to directly
connect one computer to
> the other on a 2 player LAN, especially if both
computers are close together.
>
>4. If you have multiple network adapters, the game might
be using the wrong one
> To verify this behavior, click Start / Control Panel
/ System / Hardware Tab
> / Device Manager, click the + next to Network
Adapters, right click the adapter
> which accesses the Internet, and "Disable" it from
the right-click menu. If that
> works, open Control Panel / Network Connections,
click Advanced / Advance
> Settings / click the LAN Connection and then the UP
arrow to change it's priority
> so it's at the top of the list. Test your Internet
games to see if they work this way.
>
>5. DirectX 9.0b may need to be installed on both systems:
>
http://download.microsoft.com/download/c/9/c/c9c8a1d4-7...
>
>6. Universal PnP might need to be disabled in your
router, or in Windows XP:
> a) To enable or disable UPnP in XP, click Start / Run
/ type: services.msc
> and you can then right-click Universal Plug and Play
on the list to Start it.
> b) Consult your router manual for the UPnP
instructions for your model.
>
>7. Network Adapter drivers may need to be updated on one
or all machines.
>
>8. You may need to specify the target IP using a game
specific method.
> Consult your game manual or readme file in the game
directory. For MS
> games:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;gmsnetw
>
>9. You might be specifying the Public IP instead of the
Private (LAN) IP.
> To easily find the Public and Private IP numbers of
the computer you
> are using, visit:
http://www.u.arizona.edu/~trw/games/nat_or_not.php
>
>For more in depth troubleshooting, try this MS Network
Troubleshooting article:
>http://www.microsoft.com/windowsxp/expertzone/columns/r...
>
>--
>Cheers, Windows XP MVP
Shell / User
>Jimmy S.
http://mvp.support.microsoft.com
>
>Game FAQs:
http://support.microsoft.com/default.aspx?scid=FH;[LN];gms
>Visit my Zone.com / Gaming Helpsite:
http://nibblesnbits.tk or Call / Contact
>MS Support at:
http://support.microsoft.com/default.aspx?scid=sz;en-us;top
>My advice is donated "AS IS" without warranty; nor do I
confer any rights.
>_________________________________________________________
>
>
>
>"Aaarrrrrrrrrgggggggggg"
<anonymous@discussions.microsoft.com> wrote in message
news:556101c4c6ad$06612c50$a301280a@phx.gbl...
>> Please, Please help me.
>> I have 2 PCs running Win98, Netgear 4 port hub. Both Pcs
>> have Ipx with all of the Netbui setting enabled, and TCP/IP
>> as well. Can play War Craft with no prob. either player can
>> host. My problem is with AOE/RoR. I can play single player
>> on either PC. Both can launch a multiplayer and the other
>> can SEE the game. When I attempt to join it gives error
>> "Unable to Join"
>>
>> Please, please help.
>> Regards,
>> M.
>
>
>.
>
Related resources
Can't find your answer ? Ask !
Anonymous
November 11, 2004 4:23:37 PM

Archived from groups: microsoft.public.games.ageofkings (More info?)

?????????????????????
Anonymous
November 11, 2004 10:04:00 PM

Archived from groups: microsoft.public.games.ageofkings (More info?)

I was hoping to see some other input in this thread too.
Perhaps if you post a new thread others will notice it. :-)

Cheers,
Jimmy.

"Aaarrrrrrrrrgggggggggg" <anonymous@discussions.microsoft.com> wrote in message news:5ff201c4c834$b5293dd0$a301280a@phx.gbl...
> ?????????????????????
November 29, 2004 8:20:37 PM

Archived from groups: microsoft.public.games.ageofkings (More info?)

This is really annoying. I can get lan on my XP but it
doesn't show up on the ME!!! can anyone help me???


>-----Original Message-----
>I was hoping to see some other input in this thread too.
>Perhaps if you post a new thread others will notice
it. :-)
>
>Cheers,
>Jimmy.
>
>"Aaarrrrrrrrrgggggggggg"
<anonymous@discussions.microsoft.com> wrote in message
news:5ff201c4c834$b5293dd0$a301280a@phx.gbl...
>> ?????????????????????
>
>
>.
>
!