Sign in with
Sign up | Sign in
Your question

Strange Freezing Problem with certain Games

Last response: in Windows 7
Share
February 28, 2010 3:39:41 PM

Hey everyone on Tom's Hardware! I wasn't quite sure where to post this problem, but I chose Windows 7 because the problem only started occurring after I started using it.

So far I have confirmed this happens with Sins of a Solar Empire, Supreme Commander 1, and Supreme Commander 2 (demo).

Here's what happens: After about 5-6 minutes of gameplay, the sound will cutoff, followed by the game freezing with just allowing mouse movement, then the mouse will freeze as well.

Now here's where it gets confusing. I press ctrl alt del and wait for about 2 minutes and....voila! My game starts working as if nothing had happened! Sound, graphics, everything intact.

Even more strange is that it never happens again unless I restart the gamer. After it occurred once while playing supreme commander, I played for a solid 2 hours with no problems. Once I restarted and played again, same freezing problem.

Here are my specs:
Intel Core 2 Duo E6600 (2.4Ghz)
Artic Cooling Freezer 7
EVGA Nforce 680i Motherboard
2 Gig Corsair Dominator DDR2 XMS Ram (Clocked at 1066mhz)
MSI Geforce 260GTX Video Card (Overclocked Edition)
Aerocool ZeroDBA 620Watt Power Supply
Creative Xi-Fi Gamer Sound Card
Windows 7 Ultimate (32-bit)

For the record, other games like LFD2, Starcraft, and Audiosurf do not have this problem.

This problem has been really bugging me, so any help would be greatly appreciated!
March 13, 2010 1:52:42 AM

im pretty sure its not just compatibility with windows 7 because i was running the supreme commander 2 demo just fine if that narrows down ur problem at all. However, after a little bit of searching i did find this for supcom, but idk if it directly relates but it is worth a shot and there are no other posts: So I guess if you've got a strong system with an 8800, what you should do is(i think there is a 2gb fix too but idk where):

Install the 3GB fix. (at the gpg forums, read about this, it was right for my system)
Download the 97.92 nvidia drivers.
Go into control panel and uninstall the current nvidia drivers
reboot
install the 97.92 drivers
reboot
delete the file called Game.prefs in "C:\Documents and Settings\\Local Settings\Application Data\Gas Powered Games\SupremeCommander\Game.prefs" (if you get a video error on game start)
!