Sign in with
Sign up | Sign in
Your question
Solved

Not all files copied with drag and drop windows 7

Tags:
Last response: in Windows 7
Share
July 12, 2012 2:30:11 PM

Hello,
I have tried to copy a complete file heirarchy from one drive to a folder on another drive but found several files and folders are not being copied.

There is no report of files missed or any kind of error message.

I am actually trying to copy the contents of a friends hard drive onto a backup drive since he is getting a new computer and wants to ensure nothing

is lost. I have mounted his internal 2.5 sata drive in a caddy and am copying it to my computers second internal drive.

I expected not be be able to copy certain system files. I also expected I might not to be able to copy some of his personal files due to the standard

windows system protection (I am system administrator on my PC whereas of course he was administrator on his PC where the files and folders were

created which I thought might be an issue).
When I first tried to view some folders I was asked by the system if I wanted to allow permanent administrator priviliges to them (namely his personal

directory under "Users"). I replied yes and was thereafter allowed to descend into and view those files.

Now when I copy the entire heirarchy of some 35GB I find the new folder is only 15GB. It is not just down to any compression as I have confirmed that

there is only about 1/3 of the expected number of files to what was in the original.

I have since tried individually copying some of the sub-folders that were missed and they copy fine on their own. As you can imagine, trying to

identify what has copied and what has not is a mammoth undertaking.

Has anybody had similar experiences. I have really lost faith that any of my own existing backups or future backups actually contain all the files I

require.

Thanks in advance.
a b $ Windows 7
July 12, 2012 2:41:19 PM

Are these hidden files and folders? In order to copy them in explorer (drag and drop), you have set explorer to show hidden files and folders them.
m
0
l

Best solution

a b $ Windows 7
July 12, 2012 2:48:40 PM

I would reccomend using ROBOCOPY/richcopy.

Windows seems to have a problem with the copy and paste function, with multiple GB's of files and folders.

http://technet.microsoft.com/en-us/magazine/2009.04.uti...

Robocopy is built into Windows 7, however you have to use the command prompt. The above link is for the GUI version.
Share
Related resources
July 12, 2012 3:52:20 PM

Thanks. I have just downloaded it and will give it a try tonight.
m
0
l
July 12, 2012 3:53:45 PM

Thanks. I did try that but as I said it will copy the files and sub folders that it missed if I select them individually so I don't think this can be the problem.
m
0
l
July 28, 2012 8:29:39 AM

Best answer selected by parsons_mc.
m
0
l
!