Sign in with
Sign up | Sign in
Your question

Visual Basic Exp Ed 2008 Fails In W7

Last response: in Windows 7
Share
March 1, 2010 8:39:27 PM

Does anyone know the fix for Visual Basic Express Edition 2008 on Windows 7 x64? It will not permit the creation of new projects due to registry permission issues. Please be aware that the Microsoft 'S' tool does not work. Also there are many 'Vista' suggested fixes which don't work either.

If you do offer a fix, please be sure it is for Windows 7 and not for Vista. I tried Vista fixes and they destroyed my registry...had to do an F8 boot restoration.

- grateful

PS: I am tempted to use a virtual OS and work VBE2008 from there but at this rate I'm afraid to even try that.
a c 209 $ Windows 7
March 2, 2010 2:52:47 AM

Do you have UAC turned on? I'm not totally sure about this, but I believe that one of the things that UAC enables is a virtual "per user" copy of the system-wide portion of the registry that allows that programs which normally require administrative privileges to run without them.

If you don't have UAC turned on, you might try turning it on and then doing the install and testing it to see if it works any better.
m
0
l
March 2, 2010 4:23:26 AM

SOLVED IT MYSELF!!!

I solved the problem myself. I could not find any solutions online so I played around with the registry.
I discovered the following. Please make a note of it because there will be others in the future who will have the same problem:

1. The application Visual Basic Express Edition 2008 SP1 will install perfectly on
Windows 7 x64


2. The 'SubInAcl.exe' program WILL NOT fix the permissions problem. DO NOT WASTE YOUR TIME
attempting fixes like I did. I went through the entire syntax guide looking for a possible way to fix it
but SubInAcl kept giving me errors in my DOS window.


I then decided to attempt to grant myself permission. The registry would give me errors that it could not
grant me the change. After much trial and error, I then decided to take ownership along with granting permission...PRESTO!!! problem solved!!!!!

You MUST grant yourself 'OWNERSHIP' and 'PERMISSION', then it will work.

HERE IS MY YOUTUBE VIDEO: (-ttp://www.youtube.com/watch?v=GBaV_BaN_qw)
Change the dash into an 'h'
m
0
l
!