Need driver

Hello,i am leneve y550 notebook i need the update driver for ide ata/atapi contoroller
2 answers Last reply
More about need driver
  1. nice to meet you leneve y550 notebook

    ever heard of this amazing tool called Google?
  2. Skynet has gained sentience. Without IDE drivers we may still have a chance.lol
Ask a new question

Read More

Drivers Notebooks Windows 7