USB ports, devices undetected

Certain devices ("obsolete" flash drives, iPod) are undetected in Windows 7. There are no problems with my mouse and wireless adapter, which are USB. I have tried connecting previously undetected devices through the same ports that detect the mouse and wireless adapter, which has made me further suspect the problem being with the ports, thus possibly drivers, rather than the devices (since the devices are still undetected).

I have also tried uninstalling all USB ports in Device Manager before restarting Windows, which didn't help.

Another related concern is whether the motherboard driver(s) is(are) up-to-date. I have an Intel Desktop Board LGA775 and cannot find the proper download for an update. This may fix the problem.

Suggestions?
11 answers Last reply
More about ports devices undetected
  1. "LGA775" its socket type not mobo model,

    select you mobo in the list an try to get the updates

    http://www.intel.com/products/desktop/motherboard/index.htm
  2. Is it D33025 or CPU-D975XB2?

    My guess was D33025, but I couldn't find an update for either.


    Thanks
  3. if are have intel mother board then get this tool to find you model

    http://www.intel.com/support/motherboards/desktop/sb/cs-012681.htm
  4. D975XBX2

    I need a link to the driver update. Thanks.
  5. Also, I don't know if it matters, but my processor is Intel(R) Core(TM)2 Duo, 32-bit
  6. I've learned that my motherboard is discontinued, and Intel has no plans to release driver updates for Windows 7.

    I downloaded two driver types:

    RAID: Intel® Rapid Storage Technology Driver for Intel Desktop Boards

    RAID: Marvell* Driver

    While installing, the first type's error message was, "This computer does not meet the minimum requirements for installing the software."
    While installing the second type, an error message appeared, "Can not install on a non-61xx platform."

    I'm so lost.
  7. Is your bios is upto date??
    If not update your bios!
    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=16896&ProdId=2578&lang=eng

    Also try insalling this driver (It's for vista only, but should work with Win 7 also)
    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18300&ProdId=2578&lang=eng

    Also try checking those UNDETECTED devices in some other systems.
  8. I successfully updated my BIOS. The Vista driver did not work. The devices are detected on other computers.
  9. From what I've gleaned from those links, I really need my motherboard driver update. Even with the updated BIOS, I couldn't get the RAID: Intel® Rapid Storage Technology Driver for Intel Desktop Boards or the RAID: Marvell* Driver update to install properly due to the errors mentioned previously.

    I scanned for issues and it said there was a problem, "Hardware change may have not been detected." I'm not really sure what this error messages is referring to, but I guess it's from where the attempted updates failed.

    I also manually checked all of my USB ports for Driver Updates, but they were all up-to-date.

    This seems to be more problematic than I anticipated since Intel can't/won't provide Windows 7 driver updates for my discontinued motherboard.
Ask a new question

Read More

Drivers USB Devices Wireless Adapter Windows 7