Sign in with
Sign up | Sign in
Your question

Help, Win98SE only sees 2gigs of 80 gig harddrive.

Last response: in Storage
Share
July 27, 2003 6:30:10 PM

Hello friends, Here's the history of my problem from another board;
Posted on Friday, July 25, 2003 - 5:56 pm:
I've installed an 80GB IBM harddrive in my clone computer running Win98 with an Elitegroup ECS motherboard and AMD Duron processor. During startup, the BIOS sees the 8032 MBs. FDISK sees 1 partition, 8032 MBs, PRI DOS, FAT32, 62% usage, Total disk space of 12993 MBs. My problem is my computer only recognizes 2 MBs of the 80 MB harddrive. I realized the problem when I tried to install data that exceeded 2 GB. I went to DISKSPACE and it says 2 GB. I've reinstalled Win98SE and still no change. Can anybody help? Thanks, Les
E.S.
Posted on Friday, July 25, 2003 - 7:07 pm:
As long as the bios see's the 80 gig drive the problem is FDISK in win98 not recognizing hard drives larger than 64 gig.The bulletin can be found here as well as the fix
http://support.microsoft.com/default.aspx?scid=http://s...
Les
Posted on Saturday, July 26, 2003 - 7:59 pm:
Thanks E.S., The fix helped but didn't solve the problem. In FDISK, it now says I have 78529 MBs and 10% usage. In Programs/accessories/system info, it says I have 400 MBs available of 8016 MBs (doesn't add up to 80 Gigs since I have 1600 MBs of stuff on the computer, it adds up to the same 2 gigs). In DRIVESPACE, it says I have 2 GBs. I'm still looking for the fix. Thanks Again, Les
July 27, 2003 9:58:08 PM

I'm not sure about this info, I did a little looking on the internet but lets get some more info here till a real expert comes along. Ok?

1) What is the type of ECS motherboard? It sounds to me
that you have a BIOS limitation on how large a hard disk drive it can see. This is typical of older systems

2) If the above is true there may be a Bios update at
ECS <A HREF="http://www.ecs.com.tw" target="_new">http://www.ecs.com.tw&lt;/A>

3) If there is no BIOS update that will allow you to
use the 80GB drive directly then the manufacturer usually supplies a utility that allows mapping (at the cost of some performance) to break the 528 MB, 2.1 GB, 4.2 GB, 8.4 GB, 32 GB, 64 GB and 137 GB capacity barriers

<A HREF="http://www.storage.ibm.com/hddredirect.html?" target="_new">http://www.storage.ibm.com/hddredirect.html?&lt;/A>
which led me here
<A HREF="http://www.hgst.com/hdd/support/download.htm" target="_new">http://www.hgst.com/hdd/support/download.htm&lt;/A>

Hope this is some help


The loving are the daring!
July 27, 2003 11:30:56 PM

Hehe, I've had NO problems running 80GB drives under 98SE. But I have had problems when using Win98 SETUP to format the drive. You see, Setup automatically limits your main partition to 2GB for some odd reason. The best way to do things is to boot off the Win98 CD (or floppy), choose the option to boot to DOS mode from there (with CD support if you booted off a CD), and run FDISK from the DOS prompt. Delete all old partitions and make a new one, full size, and active. Reboot when prompted and get into DOS mode the same way.

From here, if you've booted off the CD, you'll need to type in D:\ (or E, whatever MSCDEX.EXE assigned as your drive letter), followed by the enter key. Then enter CD WIN98, then enter FORMAT C:

If you booted off the floppy, just type FORMAT C:

Yes, the best option is to manually use fdisk and format to partition and format your drive.

If you loaded some kind of drive manager, you'll have to uninstall that first because it will f*ck everything up for using fdisk/format.

<font color=blue>Only a place as big as the internet could be home to a hero as big as Crashman!</font color=blue>
<font color=red>Only a place as big as the internet could be home to an ego as large as Crashman's!</font color=red>
Related resources
Can't find your answer ? Ask !
July 29, 2003 6:00:34 PM

I just finished fdisk and format on this disk. Formatting only sees 12993 MBs of the 80 gigs. It must be the motherboard. I've emailed support at ECS with no response after 24 hrs. We'll see. Thanks, Les
July 29, 2003 6:40:08 PM

<A HREF="http://www.seagate.com/support/kb/disc/faq/fdisk_80g_10..." target="_new">http://www.seagate.com/support/kb/disc/faq/fdisk_80g_10...;/A> Ok that is Seagate but it refers to a limitation on fdisk from Windows 95/98/98SE.
<A HREF="http://support.wdc.com/tips/index.asp?tip=69&static=y" target="_new">http://support.wdc.com/tips/index.asp?tip=69&static=y&l...;/A>
<A HREF="http://support.microsoft.com/default.aspx?scid=kb;en-us;Q263044" target="_new">http://support.microsoft.com/default.aspx?scid=kb;en-us;Q263044</A>

The loving are the daring!
!