Sign in with
Sign up | Sign in
Your question

After Win 7 upgrade all files now read-only

Tags:
  • Windows Explorer
  • Windows 7
  • Read Only
  • Windows XP
Last response: in Windows 7
Share
March 3, 2010 12:10:43 AM

I have a new Windows 7 machine, and I copied all my data from my XP machine over my network (simple drag-drop in Windows Explorer). Now all of those files open as read-only, even though they have no read-only attribute set on them. This affects all programs and file types. My new machine has only one user account, administrator. What happened?

More about : win upgrade files read

March 3, 2010 2:18:35 AM

Update: I also tried Windows Easy Transfer and the results were the same. I also tried taking ownership of the files, changed the owner to my admin logon and still all files open read-only, though none of them show a readonly attribute. Someone must have come across this, as all files copied from XP to Win 7 can no longer be altered by any program. Please help, because I have almost 2tb of files and cannot open them all and save with new filenames (the only remedy). I'm basically out of business...
m
0
l
March 3, 2010 2:26:39 AM

Did you delete the files off the new machine before using Win easy transfer? Try putting them in a different directory/folder. I had XP files that I could not take ownership of in the current folder but I could move them and the problem was gone.
m
0
l
Related resources
March 3, 2010 2:49:45 AM

Right click folder, properties, uncheck read-only at attributes and apply. Confirm apply changes to this folder, subfolders and files, click ok. Done
m
0
l
March 3, 2010 3:05:34 AM

It's a security feature of windows 7, It's prevent others on the homegroup(network) to makes change to your files. The read-only status don't affect you.
m
0
l
March 3, 2010 3:38:31 AM

I don't think the previous two answers understood the problem.
The read-only attribute is not checked on any of the files. They all open read-only anyway, regardless of the filetype.
There is only one user account on my computer and I cannot change the files, so of course it does affect me.

I tried deleting folders and then Easy Transferring them back but the result is always the same. Everything opens readonly even though none of the files are checked readonly.

I tried changing ownership and no matter what owner I choose the result is the same. Nothing transferred to Win7 can be changed.

If I disable UAC then the files work properly, but this should not be necessary. The problem is obviously in ownership but I can't find the fix. I never changed any Win7 defaults so why would it not work?
m
0
l
March 3, 2010 4:15:06 AM

All files and folders in Win7 will be read-only even if you the only account and you are the administrator. It's a security feature but it does not stop you from changing it.
m
0
l
March 3, 2010 4:17:39 AM

Windows 7 automatically put your system on to a homegroup and your files is share. The read-only prevent other from changing it.
m
0
l
May 12, 2010 12:25:15 PM

Maybe it prevent the other but it prevent me too.
I have exactly the same problem than the first here. I've just upgrade from XP to win 7 sunday (with the format of the C: where I install the OS) and I was able to change my file sunday and monday but since thuesday beep... I am unable to change the name of my file or to add file by right click inside some folder. I just have de opportunity to add a folder but not a file... It's crazy! And I'm prepared to come back to XP and Ubuntu... I'm administrator on the pc and the only user too.

I try to change the permissions (properties, security, edit) and check full control for all the group or users names windows add (CREATOR OWNER, SYSTEM, Administrators, User, and finally my own and unique account: Hirowa), But an error message open that windows cannot access the folder... It's not capable to open it's own security lock...

Is there anyone who found how to fix this "normal security set up"?

PS like the guy said the property of each file don't have de "read only" box check. But the folder one step higher have de box all colored (not a specific check) when I click on there to un selected this property (read only) it take time and seem to set all the things ok. But when you reopen the property window, the same box is colored.
So isn't just a question of check box.
m
0
l
!